Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th February 2009, 06:50
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default Bind not starting

Hi guys,

I've been running a pretty stable ispconfig 2 so far and recently just noticed my Bind is down and I can't get it to start. This might have happened after my recent yum update and installation of ispconfig 2.2.29.

This is what I get when I try to restart the bind server :
Quote:
[root@server1 etc]# /etc/init.d/named start
Starting named:
Error in named configuration:
/etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found

/etc/named.conf:3: parsing failed
[FAILED]
[root@server1 etc]#
I've been through a few threads and found that I needed to change my zonefiles dir to "/var/named/chroot/var/named" and I've done that, and it does stay when I go back and check it again under the management-settings-dns tab.

I do wait a few minutes to retry this but still get the same problem. I'm now stuck and don't know where to look anymore. Can someone please point me to some suggestions. Thank you
Reply With Quote
Sponsored Links
  #2  
Old 6th February 2009, 06:57
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Ok I may have resolved this on my own, but please let me know if what I did was the right thing to do. I don't want to mess anything else up.

I checked the content of my "/var/named/chroot/etc/named.comf" file and noticed the third line looked like this :

directory "/home/admispconfig/ispconfig/web/multidoc/edit";

so I changed it to this :

directory "/var/named/chroot/var/named";

and now everything seems to be working ok. I hope that was the right thing I needed to do.

Also I have not went to changed any configuration or anything, so I assumed this must have happened because of the yum update, or ispconfig update. I'm using Centos 5.2 but started from 5.0, so has anyone else ran into this? If so maybe this should be fixed for future versions. Thanks

Last edited by tal56; 6th February 2009 at 06:59.
Reply With Quote
  #3  
Old 6th February 2009, 12:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

This is not the solution for the problem as it will occur again. the real problem is that the permissions of the bind directory are wrong. Set the permissions again as described in the perfect setup guide and then set the correct bind directory in ispconfig.

Quote:
If so maybe this should be fixed for future versions.
This is a bug in yum. Yum destrooys permissions of bind folders when it updates bind instead of preventing them.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 6th February 2009, 19:37
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Hi Till,

I did do the permission changes from the perfect install but it didn't seem to fix the problem until I changed that file. Below is the steps I've done

Quote:
chmod 755 /var/named/
chmod 775 /var/named/chroot/
chmod 775 /var/named/chroot/var/
chmod 775 /var/named/chroot/var/named/
chmod 775 /var/named/chroot/var/run/
chmod 777 /var/named/chroot/var/run/named/
cd /var/named/chroot/var/named/
ln -s ../../ chroot
cp /usr/share/doc/bind-9.3.4/sample/var/named/named.local /var/named/chroot/var/named/named.local
cp /usr/share/doc/bind-9.3.4/sample/var/named/named.root /var/named/chroot/var/named/named.root
touch /var/named/chroot/etc/named.conf
chkconfig --levels 235 named on
/etc/init.d/named start
Except I did not do the two "cp" commands as I didn't want to overwrite my current configs.

In my management-settings-dns tabs here are my two fields :
named.conf: /var/named/chroot/etc/named.conf
Zonefiles Dir.: /var/named/chroot/var/named

I've kept a backup of the original named.conf before I changed the directory, so I can easily put it back. But I'd like to get this fixed right. What should I be doing?

Thanks Till
Reply With Quote
  #5  
Old 7th February 2009, 16:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by tal56 View Post
I checked the content of my "/var/named/chroot/etc/named.comf" file and noticed the third line looked like this :

directory "/home/admispconfig/ispconfig/web/multidoc/edit";

so I changed it to this :

directory "/var/named/chroot/var/named";

and now everything seems to be working ok. I hope that was the right thing I needed to do.
You could've modified some records or add a record in ISPConfig - ISPConfig would then have rewritten named.conf with the correct directory. But doing this manually is ok as well.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 8th February 2009, 01:28
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Thanks Falko

I guess from what you are saying it's ok for me to leave things as they are now. Thanks
Reply With Quote
  #7  
Old 20th January 2010, 01:28
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Hi guys, Looks like I'm having this problem again. I've just updated Centos and installed the newest ISPconfig 2, however each time I update a website Bind dies and I get this error when trying to restart it.

Quote:
[root@server1 named]# /etc/init.d/named restart
Stopping named: [ OK ]
Starting named: [ OK ]
[root@server1 named]# /etc/init.d/named restart
Stopping named: [ OK ]
Starting named:
Error in named configuration:
/etc/named.conf:3: change directory to '/home/admispconfig/ispconfig/web/multidoc/edit' failed: file not found

/etc/named.conf:3: parsing failed
[FAILED]
[root@server1 named]#
The named.conf file in the DNS setting tab, on ISPconfig is set at :
/var/named/chroot/etc/named.conf

I've ran through the DNS setup stuff from the Perfect Install for Centos 5.3 even though I'm running 5.4 now, because I don't think there's a Perfect Install for 5.4 (on a i386) system. The steps I ran through again were :

Quote:
chmod 755 /var/named/
chmod 775 /var/named/chroot/
chmod 775 /var/named/chroot/var/
chmod 775 /var/named/chroot/var/named/
chmod 775 /var/named/chroot/var/run/
chmod 777 /var/named/chroot/var/run/named/
cd /var/named/chroot/var/named/
ln -s ../../ chroot
cp /usr/share/doc/bind-9.3.4/sample/var/named/named.local /var/named/chroot/var/named/named.local
cp /usr/share/doc/bind-9.3.4/sample/var/named/named.root /var/named/chroot/var/named/named.root
touch /var/named/chroot/etc/named.conf
chkconfig --levels 235 named on
/etc/init.d/named start
Can someone tell me which named.conf file ispconfig 2 should be using ??
This one : /home/admispconfig/ispconfig/web/multidoc/edit
Or this ? : /var/named/chroot/var/named
Reply With Quote
  #8  
Old 20th January 2010, 12:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

The solution is the same. Just do what is written in this thread.

Quote:
Can someone tell me which named.conf file ispconfig 2 should be using ??
You posted the answer in #4
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 20th January 2010, 18:47
tal56 tal56 is offline
Member
 
Join Date: Oct 2007
Posts: 91
Thanks: 11
Thanked 2 Times in 2 Posts
Default

Sorry for the double post, they both had slightly different fixes, so I wasn't sure which was the right one.

I've changed both my named.conf and zonefiles to /var/named/chroot/.... now, and things seem to be fine for now.

Not sure why my zonefiles dir got changed to "/home/admispconfig/ispconfig/web/multidoc/edit", but maybe it was because of an update or something.

Thanks.
Reply With Quote
  #10  
Old 23rd January 2010, 06:35
happz happz is offline
Senior Member
 
Join Date: Feb 2008
Location: Nashville, TN
Posts: 261
Thanks: 35
Thanked 6 Times in 5 Posts
 
Default New install of fedora 12 32bit with DNS problem

Fresh install that never brought up DNS.
I ran /etc/init.d/named restart to see what I would get and this is the result::::


Starting named:
Error in named configuration:
zone localhost.localdomain/IN: loading from master file named.localhost failed: file not found
_default/localhost.localdomain/IN: file not found
zone localhost/IN: loading from master file named.localhost failed: file not found
_default/localhost/IN: file not found
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.ip6.arpa/IN: loading from master file named.loopback failed: file not found
_default/1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.ip6.arpa/IN: file not found
zone 1.0.0.127.in-addr.arpa/IN: loading from master file named.loopback failed: file not found
_default/1.0.0.127.in-addr.arpa/IN: file not found
zone 0.in-addr.arpa/IN: loading from master file named.empty failed: file not found
_default/0.in-addr.arpa/IN: file not found


ADDED NOTE: I found that I don't even have a named.conf file...how could that happen
and how can i fix it? I did the fedora 12 64Bit on a fedora 12 32 bit install with Perfect SRV
instruction. Done this many times so not sure what could have happened...

ISPConfig 2 by the way..


hAppz

Last edited by happz; 23rd January 2010 at 07:07. Reason: add data
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Hardy chrooted bind9 fails to start Djamu Server Operation 35 21st April 2010 09:28
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
ISPConfig & Bind chroot not starting awd.pt Installation/Configuration 2 29th January 2008 11:28
Problem on restart bind9 satimis Server Operation 6 30th October 2007 03:01
Bind Starting Errors dabro51 Installation/Configuration 2 28th March 2007 23:46


All times are GMT +2. The time now is 05:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.