Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st December 2009, 09:29
snowch snowch is offline
Junior Member
 
Join Date: Oct 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default webdomain ssl problem

What is the process for creating a web domain ssl?

I have tried clicking on CREATE in the SSL page. This creates ssl files in the ssl folder, but the REQUEST and CERTIFICATE are empty.

Also, I was expecting the site's .vhost file to have SSL directives, but there aren't any.

Many thanks in advance,

Chris
Reply With Quote
Sponsored Links
  #2  
Old 1st December 2009, 11:12
salami salami is offline
Junior Member
 
Join Date: Sep 2008
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Do you have the "SSL" option checked? After that the update script should create a certificate and the proper vhost directives for you.
Reply With Quote
  #3  
Old 1st December 2009, 11:20
snowch snowch is offline
Junior Member
 
Join Date: Oct 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes it is ticked.

many thanks,

chris
Reply With Quote
  #4  
Old 1st December 2009, 13:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Enter the details for the cert on the ssl tab and then select create as action and click on save. About 2 minutes later when you access the site details again, you will have the ssl cert and csr in the fields.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st December 2009, 18:23
snowch snowch is offline
Junior Member
 
Join Date: Oct 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried again. This time the ssl was created, but still no SSL directives were put into the domain's vhost file.

When I try to access https://mysite, I get the following error:

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

Many thanks in advance,

Chris
Reply With Quote
  #6  
Old 2nd December 2009, 13:24
snowch snowch is offline
Junior Member
 
Join Date: Oct 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did two different test cases, one worked, one failed:

1) new site
2) domain www.example.com
3) tick ssl
4) save
5) select domain
6) enter ssl
7) select create
8) save

vhost with SSL was created

1) new site
2) domain example.com
3) tick ssl
4) save
5) select
6) enter ssl, domain www.example.com
7) select create
8) save

vhost with SSL was not created

There is also an error in /var/log/ispconfig/cron.log:
...
chroot: cannot run command `userdel': No such file or directory
128032 semi-random bytes loaded
Generating RSA private key, 1024 bit long modulus
...
Reply With Quote
  #7  
Old 2nd December 2009, 14:55
snowch snowch is offline
Junior Member
 
Join Date: Oct 2009
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem occured when the site domain was "mydomain.com", with auto-subdomain was "www.*" and the ssl was for "www.mydomain.com".

When I changed the site domain to be www.mydomain.com, with auto-subdomain to be "None", the vhost was created with SSL.

Should this be registered as a bug?

Many thanks,

Chris
Reply With Quote
  #8  
Old 10th December 2009, 23:00
Justin Albstmeijer Justin Albstmeijer is offline
Member
 
Join Date: Dec 2007
Posts: 74
Thanks: 1
Thanked 5 Times in 5 Posts
Default

using ispconfig 3.0.6

I might have the same issue.
I too have a site domain "domain.com" with Auto-Subdomain www.

In my case I already have de crt, key and ca files..

Enabling SSL for this site domain and copying the content of these files in the SSL tab and saving , does not result in any SSL directive in the site domain config of apache.

ps. ( not sure where to copy the content of the key file)

In the ispconfig.log I also see,

10.12.2009-22:50 - DEBUG - Disable SSL for: domain.com
Reply With Quote
  #9  
Old 10th December 2009, 23:10
Justin Albstmeijer Justin Albstmeijer is offline
Member
 
Join Date: Dec 2007
Posts: 74
Thanks: 1
Thanked 5 Times in 5 Posts
Default

following the suggestion of snowch:

"When I changed the site domain to be www.mydomain.com, with auto-subdomain to be "None", the vhost was created with SSL."

does not result in a vhost with SSL for me.
Reply With Quote
  #10  
Old 14th December 2009, 16:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
 
Default

Make sure that you enable the ssl checkbox, enter the ssl certificate details and select create certificate. Pasting just a existing cert will not work as the key file is missing then and ispconfig will not create the ssl vhost for security reasons as apache wont start without this key file anyway.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
TLS Problem admins Installation/Configuration 1 19th September 2009 10:55
Problem getting squirrelmail to work with SSL (https) jkarlsen Installation/Configuration 3 6th October 2008 19:40
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
problem with SSL / recycle bin cappeonghe General 9 6th August 2006 09:38


All times are GMT +2. The time now is 22:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.