Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 20th January 2010, 13:22
TomC TomC is offline
Member
 
Join Date: Mar 2008
Posts: 37
Thanks: 2
Thanked 0 Times in 0 Posts
Default

;-) at lease I did not miss out on that one!

So, I have to ask you even more stuff... sorry, about that.

1. It looks like you defined three Webserver-Ports. Port 80 for the standard user websites. Port 8080 for ispconfig admin interface. And port 8081 for apps - whatever that means. Well, I tried to use phpmyadmin via the apps-port by setting a softlink in /var/www/apps - that didn't work, because I obviously don't have permissions to access the index.php. So firstly, is the 8081-server meant for things like this? And secondly, what did I do wrong?

2. When apache is (re-)started I get the following error messages:

Code:
root@matrux:# /etc/init.d/apache2 restart
Forcing reload of web server (apache2)...[Wed Jan 20 12:01:55 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed Jan 20 12:01:55 2010] [error] VirtualHost _default_:8081 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed Jan 20 12:01:55 2010] [warn] NameVirtualHost *:8081 has no VirtualHosts
 waiting [Wed Jan 20 12:01:57 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed Jan 20 12:01:57 2010] [error] VirtualHost _default_:8081 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Wed Jan 20 12:01:57 2010] [warn] NameVirtualHost *:8081 has no VirtualHosts
When I edit the default file in the sites-available directory by changing NameVirtualHost * to NameVirtualHost *:80, the first error is gone, but I can't access the ISPConfig admin interface anymore, because I get re-routed to the apache "It works!" message. So, what's wrong here?

Thanks again for your help!

Greetz,
Tom
Reply With Quote
Sponsored Links
  #12  
Old 20th January 2010, 13:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

1) The problem is that you used a svn version first which reconfigured your system. The apps part is under development and not finished yet and there are no apps available.

2) Also related to the fact that you installed a svn version first.

You will have to find all occurences of port 8081 in your apache config and vhost files and remove them.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 20th January 2010, 13:40
TomC TomC is offline
Member
 
Join Date: Mar 2008
Posts: 37
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Ok, so I deleted the apps.vhost file and the link in sites-enabled. Correct?

The 8081 errors are gone now, but the port 80 errors are still there:

Code:
Forcing reload of web server (apache2)...[Wed Jan 20 12:36:13 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
 waiting [Wed Jan 20 12:36:15 2010] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
Oh, and it doesn't solve my problem on how to link in with phpmyadmin.


Another issue: After some configuration I logged off from the admin console, tried to login again and get an error "Username or Password wrong." However, the admin user is still in the sys_user table (with whatever password - after all its encrypted..). What strange kind of error is that?


Once again thank you so much for your patience and great help!!!

Tom
Reply With Quote
  #14  
Old 20th January 2010, 13:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

The warnings woith port 80 are ok.

Regarding the password error, you can set a new password with phpmyadmin, it may be encrypted with md5 or crypt-md5.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 17:59
squirrelmail and postfix witoszek General 12 1st December 2009 19:07
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 18:46
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 18:17
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40


All times are GMT +2. The time now is 04:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.