Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th January 2010, 09:33
MGStudioWEB MGStudioWEB is offline
Member
 
Join Date: Jan 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default saslauthd missing mech "sasldb"

I'm migrating from a system that has sasldb enabled as a mechanism for saslauthd.
I would prefer the authentication passwords be separate from the system login (/etc/passwd) and I won't use MySQL or other database, my solution is use a db files created by saslpasswd2 (/etc/sasldb2).
After install Centos 5.4 and compile cyrus-sasl-2.1.23 this features is disabled.

saslauthd -v

saslauthd 2.1.23
authentication mechanisms: getpwent kerberos5 pam rimap shadow

How i can do?

Help me please!
Reply With Quote
Sponsored Links
  #2  
Old 13th January 2010, 10:17
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

sasldb2 is defined as auxprop

in your sasl smtpd.conf file you should define
Code:
pwcheck_method:auxprop
Reply With Quote
  #3  
Old 13th January 2010, 10:42
MGStudioWEB MGStudioWEB is offline
Member
 
Join Date: Jan 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks,

what is the MECH in /etc/sysconfig/saslauthd?

I've pam but not sasldb...
Reply With Quote
  #4  
Old 13th January 2010, 10:45
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

use this:

Code:
MECH=pam
Reply With Quote
  #5  
Old 13th January 2010, 10:54
MGStudioWEB MGStudioWEB is offline
Member
 
Join Date: Jan 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, it works but i don't understand, i've created a user with saslpasswd2 and put permit_sasl_authenticated in smtpd_recipient_restrictions of main.cf ...
postfix authenticates the user even if the saslauthd daemon is stopped!

I've read this tutorial (http://postfix.state-of-mind.de/patr...iguration.html) but i don't understand this line:

If you plan to use sasldb instead of saslauthd on your system then you should make sure the daemon will not get started automatically when you system enters the different runlevels or when you reboot. So you either disable the daemon or remove it completely.
Reply With Quote
  #6  
Old 14th January 2010, 10:30
MGStudioWEB MGStudioWEB is offline
Member
 
Join Date: Jan 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

How can Postfix autenticate sasldbuserlist users if saslauthd is stopped...?
Reply With Quote
  #7  
Old 14th January 2010, 10:51
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

You can disable the automatic starting of sasauthd in centos with i THINK

Code:
chkconfig saslauthd off
I've no experience with using centos, but it's a free version of RHEL and RHEL works like that, so i assume CentOS does that as well.
Reply With Quote
  #8  
Old 14th January 2010, 11:00
MGStudioWEB MGStudioWEB is offline
Member
 
Join Date: Jan 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your help, I've disabled the automatic starting...
I just wanted to know if it is right that Postfix authenticate the saslusers with saslauthd stopped...
Reply With Quote
  #9  
Old 14th January 2010, 11:08
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Yes, you quoted the text yourself:

Quote:
If you plan to use sasldb (yes we want that) instead of saslauthd on your system then you should make sure the daemon will not get started (cool, we just did that) automatically when you system enters the different runlevels or when you reboot. So you either disable the daemon or remove it completely.
Reply With Quote
  #10  
Old 14th January 2010, 11:25
MGStudioWEB MGStudioWEB is offline
Member
 
Join Date: Jan 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Is there a way to configure the way you use the SASL user Courier (userdb) so had a user for both authentication (POP3/IMAP and SMTP)?

Many thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
setting up a media server centos 5.2 asphix20 HOWTO-Related Questions 2 9th December 2009 16:37
Backuppc : ssh always ask for password Trollineto Installation/Configuration 11 28th March 2008 14:09
ISPConfig on a RaQ2 mattm Installation/Configuration 12 23rd January 2008 18:17
required modules missing etag1949 Installation/Configuration 2 2nd June 2006 14:13
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 11:14


All times are GMT +2. The time now is 11:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.