Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th November 2009, 21:41
jsmcdougall jsmcdougall is offline
Junior Member
 
Join Date: Nov 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Cannot Receive External Email - ISPConfig 3, Ubuntu 9.10

Hi All,

I'd appreciate any support anyone could give me with the following issue.

I set up a LAMP server according to the Perfect Server instructions for Ubuntu 9.10. Everything is working great--except that the server isn't receiving (or delivering) mail from remote addresses.

I can send and receive email fine from/to addresses on the server with SquirrelMail. I can also send emails to remote addresses from on the server just fine.

I use GoDaddy's DNS control to manage the DNS records for my domains and this is what I have set up in the domains' records.

Server
A record: mx1.serverdomain.com

Client Domain
MX record: mx1.serverdomain.com

The mail.log file doesn't show me anything unusual. I have a feeling that the remote email is not reaching the server. There are no bounce notices or error messages that I've found.

Thanks in advance.

Jesse
Reply With Quote
Sponsored Links
  #2  
Old 26th November 2009, 17:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please make sure that the MX record for your domain points to the correct server:
Code:
dig mx yourdomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th January 2010, 17:04
mattg2379 mattg2379 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email issues

Hi all.

I'm having issues with postfix as well. I followed the perfect server guide to install ispconfig on Ubuntu 8.10 on a rackspace cloud.

I am able to send and receive email internally through squirrelmail for users/mailboxes set up within ispconfig, but I am unable to send or receive external emails.

The domain name is through godaddy, and after browsing other forums, I amended the mx records to match below:

ARecord @ 204.232.206.129
CNAME www @
CNAME ftp @
MX @ mail.domainname.com
MX @ mail.domainname.com


The IP address is static on the cloud (as far as I can tell)

Im not sure if the mail.domainname.com for the MX records is true. They are set to priority 0 and 10 respectively. I added the mail subdomain to theISPconfig for that site, so it exists in the system. Im not sure if this is right or not.

I am relatively new to *nix stuff. I have set up a few Ubuntu servers before, but never email.

Please, if anyone can help me I will forever owe you beer. This is starting to stress me out and I really need to get this working ready for customers on various domains.

Many thanks in advance for your help
Reply With Quote
  #4  
Old 12th January 2010, 14:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by mattg2379 View Post
The domain name is through godaddy, and after browsing other forums, I amended the mx records to match below:

ARecord @ 204.232.206.129
CNAME www @
CNAME ftp @
MX @ mail.domainname.com
MX @ mail.domainname.com
You also need an A record for mail.domainname.com.

Are there any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
with ISPConfig, Postfix, and Courier, mail does not send or receive karazy-k Server Operation 15 20th July 2009 05:44
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31
ISPConfig - receivng mails from external not working gallen Server Operation 1 30th November 2006 09:17
can't receive email mwebb Installation/Configuration 2 15th January 2006 19:29
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 20:30


All times are GMT +2. The time now is 05:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.