Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th January 2010, 00:56
phall472 phall472 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help - pure-ftpd-mysql does not start

Hello

I am trying to set upure-ftpd-mysql on debian 5.

I followed the tutorial http://www.howtoforge.org/virtual-ho...n-debian-lenny

But when I do /etc/init.d/pure-ftpd-mysql start ore restart I receive no response

(root@T102)-(~) $ /etc/init.d/pure-ftpd-mysql restart
(root@T102)-(~) $


What is wrong?

Help!!

Thank you

Last edited by phall472; 8th January 2010 at 01:58.
Reply With Quote
Sponsored Links
  #2  
Old 8th January 2010, 16:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What are the outputs of
Code:
netstat -tap
and
Code:
ps aux | grep pure
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th January 2010, 17:31
phall472 phall472 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello

Here is netstat -tap:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:mysql *:* LISTEN 1623/mysqld
tcp 0 0 unknown.altushos:domain *:* LISTEN 3238/named
tcp 0 0 hosted-by.altush:domain *:* LISTEN 3238/named
tcp 0 0 localhost:domain *:* LISTEN 3238/named
tcp 0 0 *:ssh *:* LISTEN 3113/sshd
tcp 0 0 localhost:953 *:* LISTEN 3238/named
tcp 0 0 localhost:smtp *:* LISTEN 1972/exim4
tcp 0 52 hosted-by.altushost:ssh d24-235-190-156.h:53924 ESTABLISHED 3348/0
tcp6 0 0 [::]:www [::]:* LISTEN 2015/apache2
tcp6 0 0 [::]:domain [::]:* LISTEN 3238/named
tcp6 0 0 [::]:ssh [::]:* LISTEN 3113/sshd
tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 3238/named
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:1294 FIN_WAIT2 -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:4698 TIME_WAIT -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:1083 TIME_WAIT -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:4619 TIME_WAIT -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:1179 TIME_WAIT -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:4277 TIME_WAIT -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:4838 TIME_WAIT -
tcp6 0 0 hosted-by.altushost:www 81-174-29-42.stati:4506 TIME_WAIT -


And here is ps aux | grep pure

(root@T102)-(~) $ ps aux | grep pure
root 3364 0.0 0.0 3320 656 pts/0 S+ 16:30 0:00 grep pure
(root@T102)-(~) $

Thank you
Reply With Quote
  #4  
Old 9th January 2010, 10:20
phall472 phall472 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hello

I have been able to solve my problem.

In the tutorial http://www.howtoforge.org/virtual-ho...n-debian-lenny
on page 2 it says:
"Next, we modify /etc/inetd.conf and comment out the ftp line:

[...]
#:STANDARD: These are standard services.
#ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/pure-ftpd-wrapper
[...]"

I did not notice that there were 2 identical lines:
"#:STANDARD: These are standard services.
#Ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/pure-ftpd-wrapper
#ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/pure-ftpd-wrapper
"

So I just commented out one line, not both.

After waiting all day I decided to uninstall pure-ftpd-mysql and start over. When I noticed the 2 lines I commented the second line out. When I tried to restart pure-ftpd-mysql, EUREKA it started up!!!

I have everything working as it should.

Thank you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Monit & Munin SamTzu HOWTO-Related Questions 2 23rd September 2014 23:20
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 14:58
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 10:11
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 22:58
MYSQL Will NOT start.... Richard Server Operation 8 17th April 2006 11:54


All times are GMT +2. The time now is 16:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.