#1  
Old 13th May 2006, 20:59
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSL DocumentRoot

I have CLEARLY set my DocumentRoot in Vhosts_ispconfig.conf to /usr/share/squirrelmail and yet I get an error 404 when I https://host.domain.tld/. Also, it doesn't work when I set DocumentRoot to /var/www/web1/squirrelmail when squirrelmail is symlinked to /usr/share/squirrelmail & I can't for the life of me enable the FollowSybolicLinks Option.... Is there a conf file somewhere that I am missing?!

What gives? It works fine in http://host.domain.tld/.

Also, the SSL isn't logging ANYTHING - so I don't even have a place to start.
Reply With Quote
Sponsored Links
  #2  
Old 13th May 2006, 21:12
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ispconfig is completely ignoring any directives I give it in Vhosts...conf.

In the http section, I put in aredirect to https, in the https section, I have a DocumentRoot that it is ignoring.

After every change to conffiles, I am sure to /etc/init.d/ispconfig_server restart - but to no avail.

How do I get ssl to work? How do I log ssl errors? How to I change DocumentRoot for ssl?

I gave up on the redirect in http section and put it in a .htaccess file.
Reply With Quote
  #3  
Old 13th May 2006, 21:13
tgansert tgansert is offline
Member
 
Join Date: May 2006
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Default

(for the record, all site certificatesd are created)
Reply With Quote
  #4  
Old 14th May 2006, 16:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by tgansert
I have CLEARLY set my DocumentRoot in Vhosts_ispconfig.conf to /usr/share/squirrelmail and yet I get an error 404 when I https://host.domain.tld/. Also, it doesn't work when I set DocumentRoot to /var/www/web1/squirrelmail when squirrelmail is symlinked to /usr/share/squirrelmail & I can't for the life of me enable the FollowSybolicLinks Option.... Is there a conf file somewhere that I am missing?!
Don't change Vhosts_ispconfig.conf manually, it will be overwritten the next time you change something in ISPconfig. If you want to add additional directives, use ISPConfig's Apache Directives field.

Have a look at the end of your main Apache configuration file. There are settings for the directories where ISPConfig puts your web sites. You can add the FollowSybolicLinks directive there. Restart Apache afterwards (your main Apache, not ISPConfig's Aapche!).

Quote:
ispconfig is completely ignoring any directives I give it in Vhosts...conf.

After every change to conffiles, I am sure to /etc/init.d/ispconfig_server restart - but to no avail.
You restarted the ISPConfig system, but not your main Apache. Of course, this cannot work.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
websites outside ISPConfig guidovanh Installation/Configuration 13 7th March 2006 22:56
Same DocumentRoot for two domains todvard Installation/Configuration 2 17th February 2006 11:30
write access to wwwrun/www-data in users DocumentRoot st2xo Installation/Configuration 21 11th February 2006 13:35
Sharedip Ivan Installation/Configuration 3 7th December 2005 15:36
DNS issue and user's alias problem rosa hsiao General 3 2nd November 2005 10:03


All times are GMT +2. The time now is 20:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.