Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th January 2010, 17:15
ctql ctql is offline
Junior Member
 
Join Date: Aug 2006
Posts: 23
Thanks: 1
Thanked 3 Times in 2 Posts
Default require https for stats directory

Does anyone know how to require HTTPS for access to the stats directory? ControlScan is giving some of my customers crap for it.

I've tried adding rewrite rules to stats/.htaccess but the auth gets processed first. I think something needs to be added to the Vhosts_ispconfig.conf but my attempts there have failed as well.
Reply With Quote
Sponsored Links
  #2  
Old 14th January 2010, 10:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

http://www.howtoforge.com/forums/sho...ect+http+https
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th January 2010, 14:40
ctql ctql is offline
Junior Member
 
Join Date: Aug 2006
Posts: 23
Thanks: 1
Thanked 3 Times in 2 Posts
 
Default mod_rewrite won't work

falko,
I don't think you read the whole post. It doesn't work on apache realms because the auth module is run BEFORE mod_rewrite.
Reply With Quote
Reply

Bookmarks

Tags
https, stats

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 02:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.