Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th January 2010, 20:41
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
Default I can not access to the ISPconfig first page

Hi there,

I have gotten a bad headache after the recently installing of ISPconfig2.
After of the forst installing, I access to panel by https. but after a few hours up to now I just receive "network timeout" and can not access to the first page of it.
I reinstall it several times but...
nmap shows that port 81 in open but I can not telnet to 81 from outsite. in addition netstat shows that ispconfig in listening to port 81!!!
finally, I can login by lynx on the server itself but not from anywhere else!!!

can anyone tell me what happens?

Regards,
__________________
freesqrt
Reply With Quote
Sponsored Links
  #2  
Old 6th January 2010, 13:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post the outputs of
Code:
netstat -tap
and
Code:
iptables -L
?
Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th January 2010, 15:03
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
Default

Hi Falko,

thank you for attention,

output of "netstat -tap" is:

---------------------------------
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 6410/mysqld
tcp 0 0 *:www *:* LISTEN 21272/apache2
tcp 0 0 *:webmin *:* LISTEN 5432/perl
tcp 0 0 *:81 *:* LISTEN 21194/ispconfig_htt
tcp 0 0 mx1.tpnu.ac.ir:domain *:* LISTEN 21421/named
tcp 0 0 localhost.locald:domain *:* LISTEN 21421/named
tcp 0 0 localhost.localdoma:953 *:* LISTEN 21421/named
tcp 0 0 *:smtp *:* LISTEN 21370/master
tcp 0 0 *:https *:* LISTEN 21272/apache2
tcp6 0 0 [::]:imaps [::]:* LISTEN 4913/couriertcpd
tcp6 0 0 [::]: pop3s [::]:* LISTEN 4947/couriertcpd
tcp6 0 0 [::]: pop3 [::]:* LISTEN 4927/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 4893/couriertcpd
tcp6 0 0 [::]:ftp [::]:* LISTEN 21463/proftpd: ( acc
tcp6 0 0 [::]:ssh [::]:* LISTEN 28081/sshd
tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 21421/named
tcp6 0 0 [::]:smtp [::]:* LISTEN 21370/master
tcp6 0 1632 mx1.tpnu.ac.ir:ssh 94-182-132-93.ras:25604 ESTABLISHED 22093/sshd: tpnu [p
----------------------------------------

and "iptables -L" is:

-----------------------------
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
------------------------------

I stop the bastille-firewall service.
I use Ubuntu 8.04TLS, kernel 2.6.24-16

when I nmap from outside :

---------------------
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
25/tcp open smtp
53/tcp open domain
80/tcp open http
110/tcp open pop3
143/tcp open imap
443/tcp open https
993/tcp open imaps
995/tcp open pop3s
3306/tcp open mysql
10000/tcp open snet-sensor-mgmt
-------------------

Thank you very very much,
__________________
freesqrt

Last edited by freesqrt; 6th January 2010 at 15:10.
Reply With Quote
  #4  
Old 7th January 2010, 15:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is the server in your local network? If so, did you try to access it from within your local network or from outside? If from outside, did you configure your router to forward port 81 to your ISPConfig server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th January 2010, 11:29
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
Default

Yes, I think it is the point!!
the router ACL prevent port 81. Is there any way to change port 81 in ISPconfig to 8080 ?
because I had not any problem with ISPconfig 3 that serve us on 8080.

Regards,
__________________
freesqrt

Last edited by freesqrt; 9th January 2010 at 13:38.
Reply With Quote
  #6  
Old 10th January 2010, 17:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You must change the port in /root/ispconfig/httpd/conf/httpd.conf and /home/admispconfig/ispconfig/lib/config.inc.php. Restart ISPConfig afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
freesqrt (11th January 2010)
  #7  
Old 11th January 2010, 05:55
freesqrt freesqrt is offline
Member
 
Join Date: Dec 2007
Posts: 82
Thanks: 7
Thanked 1 Time in 1 Post
 
Default Thank you very much

It was officially hard for me to open port 81 on gateway but i changed it to 8080 and everything is O.K now.

thank you again Falko,
__________________
freesqrt
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot access ispconfig site Nu2Linux Installation/Configuration 13 3rd January 2009 15:29
Problem Installing ISPConfig on a Debian System xyhfna Installation/Configuration 17 6th February 2007 14:09
ISPConfig Installation complete but Cannot access page with IP (Debian 3.1) alexan HOWTO-Related Questions 10 24th December 2006 13:33
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
Accessing the ISPConfig Web Page nformosa Installation/Configuration 1 9th September 2005 14:13


All times are GMT +2. The time now is 04:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.