#1  
Old 11th May 2006, 17:30
databox databox is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Send email with Sympatico.ca

I try to send email with my ISP sympatico.ca but port 25 is filtered.
Does anybody use ispconfig with Bell Canada ?
I know i need to use their SMTPH.sympatico.ca as a relayhost but the SASL and TLS fail when I send a email tought postfix.

Any ideas or links are welcome.
Reply With Quote
Sponsored Links
  #2  
Old 11th May 2006, 17:36
Norman Norman is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 242
Thanks: 0
Thanked 18 Times in 14 Posts
Default

Do I understand this correctly, your postfix is configured with relayhost= smtph.sympatico.ca ?

And now you're having trouble sending through their SMTP since you arent authenticated?
__________________
http://www.xh.se
Reply With Quote
  #3  
Old 11th May 2006, 18:09
databox databox is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default smtph.sympatico.ca

Yes exactly. authentification fails when i try to send email with my server (centos 4.3 with ISPconfig)
Reply With Quote
  #4  
Old 11th May 2006, 18:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Have a look here: http://www.howtoforge.com/forums/sho...07&postcount=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th May 2006, 21:59
databox databox is offline
Junior Member
 
Join Date: May 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is my /etc/postfix/main.cf

************************************************
readme_directory = /usr/share/doc/postfix-2.1.5/README_FILES
smtpd_sasl_local_domain =
mydestination = /etc/postfix/local-host-names
smtpd_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtpd_sasl_security_options =
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = yes
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =
virtual_maps = hash:/etc/postfix/virtusertable
***************************************

And this is the maillog when i try to send an email with webmail squirrelmail :

************************************
May 11 15:08:02 idserver postfix/smtp[20259]: setting up TLS connection to smtphm.sympatico.ca
May 11 15:08:02 idserver postfix/smtp[20259]: verify error:num=20:unable to get local issuer certificate
May 11 15:08:02 idserver postfix/smtp[20259]: verify error:num=27:certificate not trusted
May 11 15:08:02 idserver postfix/smtp[20259]: verify error:num=21:unable to verify the first certificate
May 11 15:08:02 idserver postfix/smtp[20259]: Peer certficate could not be verified
May 11 15:08:02 idserver postfix/smtp[20259]: 3E895474546: to=<address@domain.net>, relay=smtphm.sympatico.ca[65.54.191.190], delay=1, status=bounced (host smtphm.sympatico.ca[65.54.191.190] said: 550 5.7.3 Requested action aborted; user not authenticated (in reply to MAIL FROM command))
May 11 15:08:02 idserver postfix/smtp[20259]: warning: Read failed in network_biopair_interop with errno=0: num_read=0, want_read=5
May 11 15:08:02 idserver postfix/cleanup[20258]: 83791474548: message-id=<20060511190802.83791474548@idserver.myserver.c om>
May 11 15:08:02 idserver postfix/qmgr[20237]: 83791474548: from=<>, size=3451, nrcpt=1 (queue active)
May 11 15:08:02 idserver postfix/qmgr[20237]: 3E895474546: removed
**********************************

I follow your instructions but I have the same problem.
Reply With Quote
  #6  
Old 12th May 2006, 11:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

I don't see
Code:
relayhost= smtph.sympatico.ca
in your /etc/postfix/main.cf. Please add it and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
Can Send email but not receive it using sendmail on debian ZeroDni Installation/Configuration 7 25th June 2006 06:04
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43
can not send mail provell Installation/Configuration 7 27th April 2006 17:23
Cannot send email - Sendmail/FC3 ingo Server Operation 2 24th April 2005 19:24


All times are GMT +2. The time now is 18:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.