#1  
Old 30th December 2009, 20:27
n0viki n0viki is offline
Junior Member
 
Join Date: Dec 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix - virtual domain

hi

i have 2 mail servers on the same subnet:

S1 mx= ex.com.pl (exchange)
S2 mx= test.ex.com.pl (postfix) //for some rison

on S2 i recenty configured postfix with Virtual Domains on mysql
based on: help.ubuntu.com/community/PostfixCompleteVirtualMailSystemHowto;

this is example of postfix main file
# Virtual Mailbox Domain Settings
virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql_virtual_domains_maps.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf
virtual_mailbox_limit = 1024000000
virtual_minimum_uid = 5000
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_transport = virtual

# Additional for quota support
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = mysql:/etc/postfix/mysql_virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_l
virtual_overquota_bounce = yes


on S2 i've created virtual domain using postfixadmin : test.ex.com.pl;

i have no problem sending mails by command line using "netcat test.ex.com.pl 25" betwen S2 & S1;


but only in this case when i use outlook or squirrelmail (from other komputer on the same subnet) and try send mail from S2 to S1 i have mesage:


Message not sent. Server replied:
Requested action not taken: mailbox unavailable
550 5.1.1 <postmaster@ex.com.pl>: Recipient address rejected: ex.com.pl

on S2 in mail.log i see:

postfix/smtpd[3696]: match_string: ex.com.pl ~? localhost
postfix/smtpd[3696]: match_list_match: ex.com.pl: no match
postfix/smtpd[3696]: dict_mysql_get_active: found active connection to host 127.0.0.1
postfix/smtpd[3696]: dict_mysql: successful query from host 127.0.0.1
postfix/smtpd[3696]: dict_mysql_lookup: retrieved 0 rows
postfix/smtpd[3696]: maps_find: virtual_alias_maps: @ex.com.pl: not found
postfix/smtpd[3696]: mail_addr_find: postmaster@ex.com.pl -> (not found)
postfix/smtpd[3696]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <postmaster@ex.com.pl>:
Recipient address rejected: ex.com.pl; from=<postmaster@test.ex.com.pl> to=<postmaster@ex.com.pl> proto=ESMTP helo=<[x.x.x.x]>
postfix/smtpd[3696]: > localhost[127.0.0.1]: 550 5.1.1 <postmaster@ex.com.pl>: Recipient address rejected: ex.com.pl


using outlook i can send message inside domain test.ex.com.pl or even from S1 to S2;


why i cannot send mail to no virutal domain like ex.com.pl, or yahoo.com?
where is problem?

Last edited by n0viki; 30th December 2009 at 20:31.
Reply With Quote
Sponsored Links
  #2  
Old 31st December 2009, 13:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Did you set up SMTP-AUTH? Do you use something like "Server requires authentication" in your email clients?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st December 2009, 14:23
n0viki n0viki is offline
Junior Member
 
Join Date: Dec 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes;

220 S2.localdomain ESMTP Postfix (Ubuntu)
ehlo test.com.pl
250-S2.localdomain
250-PIPELINING
250-SIZE 10240000
250-ETRN
250-STARTTLS
250-AUTH NTLM PLAIN DIGEST-MD5 CRAM-MD5 LOGIN
250-AUTH=NTLM PLAIN DIGEST-MD5 CRAM-MD5 LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
Reply With Quote
  #4  
Old 1st January 2010, 12:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Do you use something like "Server requires authentication" in your email clients?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 1st January 2010, 18:37
n0viki n0viki is offline
Junior Member
 
Join Date: Dec 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes i have proper settings in may email software;

i can login and send emails between users in the same virtual domain;
using smtp or imap;

but when i try to send to outside domain like yahoo or google she try to find this email addres in virutal mssql table , he dont try to resolve this internet adres;

look again this:

postfix/smtpd[3696]: match_string: ex.com.pl ~? localhost
postfix/smtpd[3696]: matchlistmatch: ex.com.pl: no match
postfix/smtpd[3696]: dictmysqlget_active: found active connection to host 127.0.0.1
postfix/smtpd[3696]: dict_mysql: successful query from host 127.0.0.1
postfix/smtpd[3696]: dictmysqllookup: retrieved 0 rows
postfix/smtpd[3696]: mapsfind: virtualalias_maps: @ex.com.pl: not found
postfix/smtpd[3696]: mailaddrfind: postmaster@ex.com.pl -> (not found)

thanks for any advise;
Reply With Quote
  #6  
Old 2nd January 2010, 15:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Is ex.com.pl an existing domain?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 2nd January 2010, 17:04
n0viki n0viki is offline
Junior Member
 
Join Date: Dec 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

th real name is diffrent but idea is the same;
i can resolv A, MX record for both domain from internet and local dns;
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
Postfix config - virtual domain mapping problem spdavid Installation/Configuration 1 24th May 2008 12:49
postfix prevent all users of a virtual domain to send emails dimitar Installation/Configuration 0 4th June 2007 11:24
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 04:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.