Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th May 2006, 10:47
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default Relaying not allowed

I have set up Outlook Express with all the account settings which all work fine, when I try and send a message to one of my other accounts not part of ISPConfig I get:

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'mhayes@touchone.co.uk'. Subject 'Test', Account: 'pop.touchonehosting.co.uk', Server: 'smtp.touchonehosting.co.uk', Protocol: SMTP, Server Response: '554 <mhayes@touchone.co.uk>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

Is there a setting somewhere in my mail config to allow this to go through.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 11th May 2006, 10:56
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

In my main.cf file I have a line "relayhosts = " does something need to be after the = sign.

Thanks
Reply With Quote
  #3  
Old 11th May 2006, 11:43
Norman Norman is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 242
Thanks: 0
Thanked 18 Times in 14 Posts
Default

ISPConfig uses Saslauthentication, you need to setup exchange to authenticate with SMTP to be able to relay outside your own server.

smtprelay = means a server which the postfix MTA will use to deliver all mail to and let to handle maildelivery for outgoing networks.

What you are looking for would be
mynetworks = 127.0.0.1/32

means it will accept anything from localhost
add more networks if you want to allow them without authentication
mynetworks = 127.0.0.1/32, 213.122.112.0/24
would allow any ip on 213.112.112.0 subnet.
__________________
http://www.xh.se
Reply With Quote
  #4  
Old 11th May 2006, 12:03
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

I want to only allow authenticated users to relay messages to other domains from outside the current domain.

If you know what I mean.
Reply With Quote
  #5  
Old 11th May 2006, 17:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

You must enable "Server requires authentication." in your email client, that's all.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 20:25
Options not allowed here sushestvo Installation/Configuration 3 20th October 2005 22:57
Number of allowed domains times 2? cstone Installation/Configuration 9 11th October 2005 02:06


All times are GMT +2. The time now is 06:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.