Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th December 2009, 12:57
modir modir is offline
Junior Member
 
Join Date: Dec 2009
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default postfix/smtpd[29564]: fatal: unsupported dictionary type: mysql

Hi,

I followed this guide here: http://www.howtoforge.com/perfect-se...ispconfig-3-p4 but I do not get mysql support.

I always get the following messages when I start postfix:
Dec 14 13:29:43 shared postfix/qmgr[29499]: fatal: unsupported dictionary type: mysql
Dec 14 13:29:44 shared postfix/master[20630]: warning: process /usr/libexec/postfix/qmgr pid 29499 exit status 1
Dec 14 13:29:44 shared postfix/master[20630]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling

While compiling I get several thousands time the following messages inbetween:
warning: "/*" within comment

Is this normal?

as you can see from this statement here:
gcc -Wmissing-prototypes -Wformat -fPIC -DHAS_LDAP -DLDAP_DEPRECATED=1 -DHAS_PCRE -I/usr/include/pcre -DHAS_MYSQL -I/usr/include/mysql -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl -DUSE_TLS -I/usr/kerberos/include -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -I. -DLINUX2 -c auto_clnt.c

MySql should have got compiled in. So, I not sure where I would have to search next.
Reply With Quote
Sponsored Links
  #2  
Old 14th December 2009, 13:39
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

Did you set:

Code:
%define MYSQL 1
in /usr/src/redhat/SPECS/postfix.spec?

in other words, double check this part of the how-to:
11 Apply Quota Patch To Postfix
Reply With Quote
  #3  
Old 14th December 2009, 16:10
modir modir is offline
Junior Member
 
Join Date: Dec 2009
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yes, I did set this. These are the first few lines of this file:

%define LDAP 2
%define MYSQL 1
%define PCRE 1
%define SASL 2
%define TLS 1
%define IPV6 1
%define POSTDROP_GID 90
%define PFLOGSUMM 1


I think you can even recognize it by what I posted before (I guess):
gcc -Wmissing-prototypes [........] -DHAS_MYSQL -I/usr/include/mysql ......

And I did check the rest of the file again. And I didn't find anything wrong.
Reply With Quote
  #4  
Old 14th December 2009, 16:14
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,002 Times in 3,911 Posts
Default

Have you tried to restart the complete server to be really sure that you run the new postfix binary? Ckeck also the date and timestamp of the binary to ensure that it really got replaced.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 14th December 2009, 19:00
modir modir is offline
Junior Member
 
Join Date: Dec 2009
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Hi Till,

You got me in the right direction... It looks like "service postfix restart" uses the same binaries. Only "service postfix stop / service postfix start" loads the new binaries.

Thanks for your help.
Reply With Quote
Reply

Bookmarks

Tags
centos 5.4 64bit, mysql, postfix

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix error: fatal: unsupported dictionary type: mysql -- throttling RomaSvcs Installation/Configuration 8 30th November 2012 17:01
fatal: unsupported dictionary type: mysql rdw Installation/Configuration 5 16th April 2010 20:22
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
smtp is error!!! fhawk Installation/Configuration 2 7th April 2009 13:17
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11


All times are GMT +2. The time now is 22:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.