Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th December 2006, 02:49
dkrysak dkrysak is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default assp tutorial port 25 woes

Hi there - I was following the assp tutorial, and all seems to have gone well, with the exception of my port 25.

Now as the tutorial suggests, you configure postfix to listen on 127.0.0.1:25 and the assp on p.ub.l.ic:25.

So what I did was change my main.cf for postfix - inet_interfaces to localhost, then edited the master.cd to have the 127.0.0.1:smtp entry.

Once I restart postfix and start assp, i then ran

# netstat -tupl

To check for my listening ports.... I can see my localhost smtp, however nothing for my public ip:25

IS there a setting somewhere for assp to bind it to a particular IP or interface? I am assuming the port 25 is being glommed by postfix. I know I could change the port for postfix, etc, however I would prefer to work with 25 as the tutorial suggested.

Also how will assp effect my smtp auth and my postfix fore relaying outbound email?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 19th December 2006, 12:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Quote:
http://example.com:55555

and log in with any name and the password nospam4me.

So here we are in the land of the many possibilities.

You might wand to use the TestModeOptions so everything passes tru but the database gets populated, after a while you uncheck the options and rebuild your filter. Every thing is now in full swing.

Tell assp to listen to 123.123.123.123:25 and forward to localhost:25.
Have you logged into ASSP on port 55555 with your webbrowser and changed the settings that it listens only to port 25 on your public IP?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th December 2006, 20:05
dkrysak dkrysak is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I did. I made sure of it....

I had done the basic config based on info I had searched for on the net.
Reply With Quote
  #4  
Old 21st December 2006, 19:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What are the outputs of
Code:
ifconfig
and
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st December 2006, 19:56
dkrysak dkrysak is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ifconfig

eth0 Link encap:Ethernet HWaddr 00:20:ED:72:B1:50
inet addr:64.40.xxx.xxx Bcast:64.40.xxx.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:50610146 errors:0 dropped:0 overruns:0 frame:0
TX packets:1501431 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:502824082 (479.5 Mb) TX bytes:735428158 (701.3 Mb)
Interrupt:11 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:318937 errors:0 dropped:0 overruns:0 frame:0
TX packets:318937 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:235703586 (224.7 Mb) TX bytes:235703586 (224.7 Mb)

netstat

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:55555 *:* LISTEN 26229/perl
tcp 0 0 *:ldap *:* LISTEN 3056/slapd
tcp 0 0 *:mysql *:* LISTEN 3148/mysqld
tcp 0 0 *op3 *:* LISTEN 3096/xinetd
tcp 0 0 *:imap *:* LISTEN 3096/xinetd
tcp 0 0 *:http *:* LISTEN 3226/httpd
tcp 0 0 *:ftp *:* LISTEN 3106/vsftpd
tcp 0 0 *:ssh *:* LISTEN 3080/sshd
tcp 0 0 localhost.localdom:smtp *:* LISTEN 26219/master
tcp 0 0 localhos:x11-ssh-offset *:* LISTEN 25989/0
tcp 0 0 *:https *:* LISTEN 3226/httpd
Reply With Quote
  #6  
Old 22nd December 2006, 15:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by dkrysak
tcp 0 0 localhost.localdom:smtp *:* LISTEN 26219/master
Postfix is listening on port 25 on 127.0.0.1, but there's no process listening on port 25 on 64.40.xxx.xxx...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd December 2006, 21:38
dkrysak dkrysak is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yup! In my original message I stated that....



Quote:
IS there a setting somewhere for assp to bind it to a particular IP or interface? I am assuming the port 25 is being glommed by postfix. I know I could change the port for postfix, etc, however I would prefer to work with 25 as the tutorial suggested.

Also how will assp effect my smtp auth and my postfix fore relaying outbound email?
Reply With Quote
  #8  
Old 23rd December 2006, 17:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Please direct your browser to http://example.com:55555 (replace example.com with your server's IP address 64.40.xxx.xxx) and then tell assp to listen on 64.40.xxx.xxx:25.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 30th December 2006, 22:03
dkrysak dkrysak is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please direct your browser to http://example.com:55555 (replace example.com with your server's IP address 64.40.xxx.xxx) and then tell assp to listen on 64.40.xxx.xxx:25.
I had done that before my original posting...
Reply With Quote
  #10  
Old 31st December 2006, 21:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Does your firewall allow connections on port 55555?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 17:33
Ask: ASSP -> between SMTP Destination & Listen Port abadi HOWTO-Related Questions 3 18th December 2006 15:15
My php scripts don't send e-mail html forms. CombatGod Installation/Configuration 5 8th November 2006 11:16
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Sequring TPS Fedora4 Hagforce HOWTO-Related Questions 17 28th March 2006 18:36


All times are GMT +2. The time now is 21:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.