Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th August 2006, 14:38
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default ftp login very slow

I have two servers configured according to the 'perfect setup' (both are Debian Sarge, ispconfig 2.2.6)

Everything works great - the only problem is the slow ftp access. In fact, it takes up to 15 seconds to log in to any ftp account on both servers (from any other computer). The delay happens after the message "Socket connected. Waiting for welcome message..." is displayed.

Here is a part of the cuteftp log - as you can see, this time it took 10 seconds to log in.

STATUS:> [25.08.2006 16:33:10] Getting listing ""...
STATUS:> [25.08.2006 16:33:10] Resolving host name studiograd.com...
STATUS:> [25.08.2006 16:33:10] Host name studiograd.com resolved: ip = 85.249.237.53.
STATUS:> [25.08.2006 16:33:10] Connecting to FTP server... studiograd.com:21 (ip = 85.249.237.53)...
STATUS:> [25.08.2006 16:33:10] Socket connected. Waiting for welcome message...
[25.08.2006 16:33:20] 220 ProFTPD 1.2.10 Server (Debian) [85.249.237.53]
STATUS:> [25.08.2006 16:33:20] Connected. Authenticating...

I thought it was a firewall issue - but no, it happens all the same even if the firewall is disabled.

Please help - is there something I can do to speed this up?
Reply With Quote
Sponsored Links
  #2  
Old 25th August 2006, 17:53
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Plese check that you have these two lines in your /etc/proftpd.conf file:

IdentLookups off
UseReverseDNS off

and no other occurences of these two config options.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th August 2006, 19:51
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default

Thank you for your advice, but unfortunately it did not help.

IdentLookups off was already in my config file, so I only added UseReverseDNS off - but it changed nothing. Still 10 seconds. (I even restarted the server for good measure).

I also uncommented the line DelayEngine off (in the hope that this is the cause of the problem) - but it didn't help either.

Here is my proftpd.conf (comments are stripped):
ServerName "Debian"
ServerType standalone
DeferWelcome off
MultilineRFC2228 on
DefaultServer on
ShowSymlinks on
TimeoutNoTransfer 600
TimeoutStalled 600
TimeoutIdle 1200
DisplayLogin welcome.msg
DisplayFirstChdir .message
ListOptions "-l"
DenyFilter \*.*/
Port 21
MaxInstances 50
User nobody
Group nogroup
Umask 022 022
AllowOverwrite on
DelayEngine off
DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."
UseReverseDNS off
Include /etc/proftpd_ispconfig.conf
Reply With Quote
  #4  
Old 25th August 2006, 22:09
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
Default

Not sure if this will help, but it's worth a try..
If you have a firewall running, turn it off and see if the login is faster.

Make sure you turn the firewall on again after testing, and report back the results..
Reply With Quote
  #5  
Old 25th August 2006, 22:40
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default

I already tried it with the firewall on and off - there's no difference...
Reply With Quote
  #6  
Old 26th August 2006, 14:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you try with both active and passive transfers in your FTP client?
This thread might also be of interest: http://www.howtoforge.com/forums/sho...ighlight=60000
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 26th August 2006, 15:20
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default

Thank you for your help, but still the problem persists. I tried both active and passive transfers (I even used different ftp clients) - but it's always 10 seconds after "Socket connected.Waiting for welcome message..." It may not seem like a big problem, but in fact it quickly gets very frustrating if you test a site and have to frequenly upload files to see how they look on the server... (By the way, even if I don't disconnect, there's a 10 seconds pause before I can upload some new files). Also I have to think about my clients who will not be happy Anyway, thank you for your help, I'll keep trying to find the cause of this.

STATUS:> [26.08.2006 17:15:55] Socket connected. Waiting for welcome message...
[26.08.2006 17:16:05] 220 ProFTPD 1.2.10 Server (Debian) [85.249.237.53]
STATUS:> [26.08.2006 17:16:05] Connected. Authenticating...

Last edited by dimas; 26th August 2006 at 15:23.
Reply With Quote
  #8  
Old 26th August 2006, 17:15
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default

I'm coming closer to a solution, but questions still remain...

First of all, I can now log in without any delays if the firewall on my CLIENT pc is totally disabled. I didn't try it before because my client pc could log in to other ftp servers without delays.

Well, now I know that the problem lies in the relationship between proftpd server and my windows xp sp-2 built-in firewall.

Strangely enough, there are no delays ONLY if the client firewall is totally disabled. With the client firewall switched on there is always a 10-second delay (even though I opened ports 20,21 and 60000-60005 in my client firewall).

What other ports do I need to open in my client firewall? And why is it that my client firewall produces delays ONLY with proftpd, not with other ftp servers?
Reply With Quote
  #9  
Old 26th August 2006, 17:54
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default

I have found out (by studying c:/windows/pfirewall.log) that the client pc port that needs to be opened is 113. Indeed, once it is opened, there are no delays. So now everything is OK, but...

I can't say that it is an easy decision to tell every client who has windows xp sp-2 to open this port on their computers in order to work comfortably. I repeat that with this port closed other ftp servers can be reached without delays.

So - I wonder is there a way to configure proftpd so that client pcs with port 113 closed could work without delays...
Reply With Quote
  #10  
Old 27th August 2006, 00:34
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
 
Default

I have the answer finally, after many hours of searching, trial and error...

Of course, the answer is very simple.

The 'perfect setup' howto says that the following lines should be added to proftpd.conf:

DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."

BUT IF ADDED LIKE THIS, THE CHANGES WILL NOT AFFECT THE VIRTUAL HOSTS!

So actually it should be like this:
<Global>
DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."
</Global>

Then everything will be OK - now there is no need to open port 113 on client pcs.

I hope this solution will help somebody.
Reply With Quote
The Following 20 Users Say Thank You to dimas For This Useful Post:
ahoivik (26th April 2008), andron26 (14th October 2010), baboonish (28th February 2008), burlyhousetech (17th June 2008), carbon (14th October 2007), commentator (2nd August 2009), createch (3rd May 2010), dabro (12th September 2007), dimitrivisser (26th March 2010), draecos (14th February 2008), haaglin (29th March 2008), hairydog2 (17th March 2008), JohnMH (29th March 2010), luchs3 (8th November 2008), mturillo (18th November 2009), Numerizen (13th March 2009), pillul (10th February 2010), Sammy (24th March 2008), SupuS (18th August 2008), vulfs (27th March 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending email (connect, login) = slow TheRudy Server Operation 7 8th July 2006 12:46
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 12:13
Statistics error Piccent Installation/Configuration 8 13th March 2006 00:13
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 18:11
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 12:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.