Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st December 2009, 15:19
playalistic playalistic is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default imapd: Error reading ACLs for INBOX..Junk: Invalid argument

I'm getting lots of these showing up in the logs:

Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument
Dec 1 13:44:25 cmg-nix01 imapd: Error reading ACLs for INBOX..Junk: Invalid argument

I'm pretty certain this started since I added a filter to move SPAM into the .Junk folder. I since removed the filter and restarted the necessary services but it is still appearing in the mail.log.

I've also deleted the folder through the webmail client (Roundcube) which I installed separately and recreated it but no dice.

Can anyone help please?!
Reply With Quote
Sponsored Links
  #2  
Old 2nd December 2009, 09:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,595
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

The folder name must be 'Junk' and not '.Junk'.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd December 2009, 11:22
playalistic playalistic is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Thanks for the reply. I kinda guessed the problem with the name. I included the . in front of the mailbox name when I created the filter initially as I didn't realise it was included for me by default.

I've since deleted the filter, how can I get rid of this message and the associated mailbox?

Cheers!
Reply With Quote
  #4  
Old 2nd December 2009, 11:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,595
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Check if the maildir with the wrong name still exists in /var/vmail/domain.com/user/.... If thats the case, delete it there on the shell.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd December 2009, 11:31
playalistic playalistic is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default

This is what I'm seeing in the folder for this user:

Code:
drwx------ 10 vmail vmail   4096 2009-12-02 10:23 .
drwx------  7 vmail vmail   4096 2009-11-24 12:49 ..
drwx------  2 vmail vmail   4096 2009-12-01 19:05 courierimapkeywords
-rw-r--r--  1 vmail vmail    251 2009-12-01 14:34 courierimapsubscribed
-rw-r--r--  1 vmail vmail   3673 2009-12-02 10:23 courierimapuiddb
drwx------  2 vmail vmail 221184 2009-12-02 10:26 cur
drwx------  6 vmail vmail   4096 2009-11-20 18:42 .Drafts
-rw-rw----  1 vmail vmail     56 2009-12-02 09:32 ispconfig_mailsize
drwx------  6 vmail vmail   4096 2009-12-01 14:35 .Junk
-rw-r--r--  1 vmail vmail   1805 2009-12-02 10:23 maildirsize
drwx------  2 vmail vmail 163840 2009-12-02 09:34 new
drwx------  6 vmail vmail   4096 2009-12-01 12:53 .Sent
drwx------  2 vmail vmail   4096 2009-12-02 10:29 tmp
drwx------  6 vmail vmail   4096 2009-12-02 10:23 .Trash
The .Junk folder is OK isn't it? Or shall I delete it. Thanks again dude.
Reply With Quote
  #6  
Old 2nd December 2009, 11:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,595
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Yes, the .Junk folder is ok. Take a look in the file courierimapsubscribed if the folder with the wrong name is still listed there and if thats the case, remove that line in the file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
playalistic (2nd December 2009)
  #7  
Old 2nd December 2009, 11:42
playalistic playalistic is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

That did it, cheers.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
squirrelmail and postfix witoszek General 12 1st December 2009 18:07
Debian Lenny apt-get update failed to fetch qriz Installation/Configuration 3 31st October 2009 22:19
Need help setting up domainpop with postfix kameelperdza Installation/Configuration 6 15th June 2009 07:49
Mail not working epicuniversal General 5 13th June 2009 08:24
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22


All times are GMT +2. The time now is 17:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.