#1  
Old 20th November 2009, 09:59
iskra iskra is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default mySQL recognized

Hey all... I just installed the Debian Lenny Perfect Server setup with ISPC3. ISPConfig is not recognizing MySQL, and in turn postfix doesn't work.
netstat -tap | grep mysql
Code:
tcp        0      0 *:mysql                 *:*                     LISTEN      17088/mysqld
My /etc/hosts has the localhost in it... tryed restarting mySQL and it starts and stops fine. Not exactly sure where to go from here. .. what should I be checking to see if it's broken?
Reply With Quote
Sponsored Links
  #2  
Old 20th November 2009, 10:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,384 Times in 4,231 Posts
Default

ISPConfig is not checking for mysql. So what do you mean that it did not recognizes it?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th November 2009, 10:15
iskra iskra is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

In "Show Services" it shows SMTP-Server Offline and mySQL-Server Offline.

I get this error message for mail "Nov 19 23:17:40 iskra-server postfix/trivial-rewrite[16887]: fatal: mysql:/etc/postfix/mysql-virtual_relaydomains.cf(0,lock|fold_fix): table lookup problem"
Reply With Quote
  #4  
Old 20th November 2009, 10:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,384 Times in 4,231 Posts
Default

Which exact ispconfig version?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th November 2009, 10:19
iskra iskra is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ISPConfig 3.0.1.6
Reply With Quote
  #6  
Old 20th November 2009, 19:30
iskra iskra is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok. So I read that table lookup issues can be a result of permissions. I chmodded /etc/postfix/mysql* to 777 to see if that would help and restarted mysql and postfix. No difference... probably a laughable attempt at fixing the problem =) but I'm really lost here.

Now, what should those files be set to permission wise and where should I start in fixing original problem?

I can log in with the user and pass specified in /etc/postfix/mysql-virtual_relaydomains.cf
Reply With Quote
  #7  
Old 1st December 2009, 12:07
antonibede antonibede is offline
Junior Member
 
Join Date: Oct 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Can anyone suggest me best tips and webs for
SQL information as well guidence. I am new for this community
i need some solution..
__________________
autism
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
Problem installing MySQL on suse 10.3 Txchaser Installation/Configuration 20 18th April 2008 01:05
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Messed up ISPConfig-2.2.8 Upgrade Morons Installation/Configuration 4 29th November 2006 12:17
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 16:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.