Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th November 2005, 17:17
krazy1 krazy1 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question The Perfect Setup - Debian Sarge (3.1) Issues

I have been working my way through the Debian Sarge mail server setup and have run into an issue. When I get to:

Now start saslauthd:

/etc/init.d/saslauthd start

I get the following:

Starting SASL Authentication Deamon: (failed).

I can't figure out why this is failing and I am not sure where to look. I have double checked that I followed the instructions and everything I have matches the instructions. Any help is greatly appreciated.

TIA
Reply With Quote
Sponsored Links
  #2  
Old 8th November 2005, 19:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Do you see anything in the mail log (/var/log/mail.log)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd January 2006, 16:25
inversecow inversecow is offline
Junior Member
 
Join Date: Jan 2006
Location: Halifax, NS, Canada
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb Similar issues with the Ubuntu 5.10 ISP-Server setup

Hello,

I have noticed similar issues with the above mentioned How-to. I have verified all of the conf. files mentioned in the How-to itself, and have been left at a loss. The only error is "Starting SASL Authentication Daemon: (failed)." No entry is made to the mail log (/var/log/mail.log).

That being said, I happened to enter the following in the console and SASL started no problem:

sudo /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -a pam

The only thing I can think of is this. Some how during the process of activation, the startup script does not make reference to the "default settings" file (/etc/default/saslauthd), thus it does not pull the needed info to properly execute.

I am happy to get SASL to start, however I am baffled as to why it did not work as expected.
Reply With Quote
  #4  
Old 3rd January 2006, 17:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by inversecow
Hello,

I have noticed similar issues with the above mentioned How-to. I have verified all of the conf. files mentioned in the How-to itself, and have been left at a loss. The only error is "Starting SASL Authentication Daemon: (failed)." No entry is made to the mail log (/var/log/mail.log).

That being said, I happened to enter the following in the console and SASL started no problem:

sudo /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -a pam
Did you try to start saslauthd as root?
Run
Code:
/etc/init.d/saslauthd start
as root.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd January 2006, 17:26
inversecow inversecow is offline
Junior Member
 
Join Date: Jan 2006
Location: Halifax, NS, Canada
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the quick reply. :-)

I tried this as root, and the result was the same(Starting SASL Authentication Daemon: (failed).) Is there a method to produce more verbose error messages within the init.d scripts? Perhaps such would give a direction to move in.
Reply With Quote
  #6  
Old 3rd January 2006, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you follow the Ubuntu tutorial to the letter? Maybe you made a typo somewhere. Please check your settings again (e.g. configuration files, paths, etc.).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th May 2006, 15:00
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

Same problem here.
Starting SASL Authentication Deamon: (failed)

I installed ISPConfig 2.2.2 on two Debian boxes in past 7 days.
First time ther were no errors.
Today there are errors.

Only difference between two installs is MySQL 4.0xx and 4.1
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3
Reply With Quote
  #8  
Old 6th May 2006, 18:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Make sure you follow the tutorial to the letter. It is working for me like that, and I've used it so many times now to set up servers and never had any problems.
Maybe you made a typo somewhere.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 9th May 2006, 12:16
Norman Norman is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 242
Thanks: 0
Thanked 18 Times in 14 Posts
Default

Edit. I had the same issues when upgrading from mysql-server 4.0 to 4.1.
If you cant stop saslauthd verify that it isn't still running

/etc/init.d/saslauthd stop
If it says "Stopping SASL Authentication Daemon: (not running)."
then run:
ps aux|grep sasl

If you get any lines such as:
root 13413 0.0 0.0 6556 1580 ? Ss 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13414 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13415 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13416 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root 13417 0.0 0.0 6556 1580 ? S 12:20 0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam


issue command:
killall -9 saslauthd

and then try to run /etc/init.d/saslauthd start
should return"Starting SASL Authentication Daemon: saslauthd.".

Good luck!

Last edited by Norman; 9th May 2006 at 12:23.
Reply With Quote
  #10  
Old 9th May 2006, 12:44
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
 
Default

Quote:
Originally Posted by falko
Make sure you follow the tutorial to the letter. It is working for me like that, and I've used it so many times now to set up servers and never had any problems.
Maybe you made a typo somewhere.
Falko, I do not think that anyone is actually typing.
Why should we? You created very good "copy & paste" manual.
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pop3 service alone is failed in "The Perfect Setup - Debian Sarge (3.1)" nandhu HOWTO-Related Questions 60 5th August 2008 15:15
The Perfect Setup - Debian Woody (3.0)... sending mail from my XP box? ExCIA HOWTO-Related Questions 17 27th June 2007 18:31
Debian Sarge Perfect Setup Rocky Installation/Configuration 2 4th November 2005 16:32
Perfect setup (debian sarge) Pelle Installation/Configuration 4 11th October 2005 17:17
Perfect Setup for Debian Sarge benny HOWTO-Related Questions 1 8th May 2005 13:41


All times are GMT +2. The time now is 01:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.