Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th November 2009, 08:13
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default Creating of databases stop working

I am not able to create any databases even though it shows up in ispconfig. Looking at the ispconfig.log file, the last entries was back in May 2009. It showed a lot of errors while dropping multiple databases, errors dropping users and so on.

What can be causing this? Are there any other logs to see what ispconfig is doing when attempting to create the database?

I rebooted both ispconfig servers but still no luck. I have a multiserver setup but the second ispconfig server only does dns.

I'm running version 3.0.1.1
Reply With Quote
Sponsored Links
  #2  
Old 24th November 2009, 08:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,214 Times in 4,089 Posts
Default

Most likely the job processing was halted due to a fatal error to avaoid any damage of your setup. Please take a look in the system log in the ispconfig monitor and post the error that you get there. Also take a look at the jobqueue and post which action is causing the system to stop.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th November 2009, 08:36
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

It doesn't show anything in the system logs. Is it because I use Fedora?

Here's the output of job queue:
===
2009-11-23 23:20 ispc1.domain.com Insert web_database
2009-11-23 22:46 ispc1.domain.com Insert web_database
2009-11-23 22:46 ispc1.domain.com Delete web_database
2009-11-23 22:42 ispc1.domain.com Update web_database
2009-11-23 22:42 ispc1.domain.com Update web_database
2009-11-23 22:38 ispc1.domain.com Insert web_database
2009-11-23 22:36 ispc1.domain.com Delete web_database
2009-11-23 22:23 ispc1.domain.com Insert web_database
2009-11-23 22:23 ispc1.domain.com Delete web_database
2009-11-23 22:05 ispc1.domain.com Insert web_database
===

Is web_database just a name for inserting into the main database or the creating of the database?
Reply With Quote
  #4  
Old 24th November 2009, 08:40
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I just notice now... nothing shows up in Monitoring for my Main ispconfig server. If I click on the second server from the menu, i see all the logs, system logs, maillogs , etc..,

Looking at the system logs from the console itself /var/log/messages, I see a few of these:

Nov 23 22:21:51 ispc1 mydns[2212]: 2.0.0.10.in-addr.arpa.: error loading SOA: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)

Nov 23 22:29:12 ispc1 mydns[2212]: 33.168.192.in-addr.arpa.: error loading SOA: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (errno=2)

Last edited by binaryrogue; 24th November 2009 at 08:49.
Reply With Quote
  #5  
Old 24th November 2009, 08:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,214 Times in 4,089 Posts
Default

There was a bug in older ispconfig releases regarding the logging issue which was solved in 3.0.1.6.

Regarding the original problem. Please post the errors that you got on the server wehere your databases should be created and then check the monitor if the first job is locked (the first by date, you have to go to the last page in the list to see it as they are listed chronologically).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 24th November 2009, 08:54
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Are you talking about the Job queue? The first entry on Page 4 shows:

2009-11-20 13:28 ispc1.domain.com Update dns_soa

This date was 3 days ago. Does this mean, this entry has not been executed yet?
Reply With Quote
  #7  
Old 24th November 2009, 09:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,214 Times in 4,089 Posts
Default

Quote:
This date was 3 days ago. Does this mean, this entry has not been executed yet?
Yes. Everything shown in the jobqueue is pending. Adn what about my other questions?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 24th November 2009, 09:16
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I'm not sure what errors you're about Till. When I create the database, it shows up in ispconfig like it was there.

If I click on Monitor and try to view the main server (ispc1), all stats and log shows:


Data from: ????-??-?? ??:??
No data about the disk usage available at the moment. Please check again later.

Before, it would always show the logs and such.

Last edited by binaryrogue; 24th November 2009 at 09:19.
Reply With Quote
  #9  
Old 24th November 2009, 09:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,214 Times in 4,089 Posts
Default

Run this command as root user (dont use sudo) on the shell of every server and post the output:

/usr/local/ispconfig/server/server.sh
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 24th November 2009, 09:33
binaryrogue binaryrogue is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

[root@ispc1 ~]# /usr/local/ispconfig/server/server.sh
PHP Warning: Module 'fileinfo' already loaded in Unknown on line 0
/sbin/mdadm
/usr/bin/fail2ban-client
finished.

===========

[root@ispc2 ~]# /usr/local/ispconfig/server/server.sh
finished.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
Monit & Munin SamTzu HOWTO-Related Questions 1 4th May 2008 18:03
DNS stop working MZH General 3 22nd February 2008 11:10
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 22:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.