#1  
Old 8th December 2009, 20:27
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 39 Times in 33 Posts
Default Virtual hosts

I've been having a little trouble setting up virtual hosts in apache2. The server works and is visible from the world Through the router using port forwarding.

I attempted to use webmin to set up two virtual hosts in addition to the default host. I've used to spare domain names I have registered and used web forwarding to point them to the static ip address of the router. This works but both show the default doc root page not their own supposed doc root pages.

I presemed they would use their client side headers to be recognised by apache and get to the right virtual host.

Is this likely to be a problem with just using web forwarding or is the virtual host not setup properly?

David
Reply With Quote
Sponsored Links
  #2  
Old 9th December 2009, 08:51
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

That is a problem with your apache configuration, name based virtual hosting works by using the Host: header in the request not the ip address.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
Toucan (15th December 2009)
  #3  
Old 15th December 2009, 01:15
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 39 Times in 33 Posts
 
Default

now my name servers are working it all seems in order. thanks
Reply With Quote
Reply

Bookmarks

Tags
apache, forward, virtual

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11, ISPconfig and virtual hosts robyoko Installation/Configuration 9 23rd September 2009 18:09
Apache Virtual Hosts - I have never gotten this right. DazzyB Server Operation 2 24th December 2007 13:37
SSL for virtual hosts on one certificate rbartz Tips/Tricks/Mods 8 20th November 2007 17:59
ISPconfig Virtual Hosts + Perfect setup Problem ? orasis Installation/Configuration 5 16th March 2007 10:46
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 12:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.