Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th November 2009, 21:39
rootfive rootfive is offline
Junior Member
 
Join Date: Nov 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig 3.0.1.6, suphp and joomla problem

Hi,

I installed the ispconfig 3.0.1.6 using how to forge manual and it is flawless in installation.
After I created the first site with suphp and I tried to install joomla, it gives me the error from joomla with session.save_path. If you use mod_php, I can install joomla without any problem. Can you please guide what should I do or change?

Thanks,
Wilco
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2009, 12:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,489 Times in 4,321 Posts
Default

Please post the exact error message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th November 2009, 18:49
dc41 dc41 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I too have this problem. Mod-PHP works but isn't allowed "write" privileges in the client's web directory. When I attempt to use SuPHP the error message Joomla's installer returns:

"An error has occurred:

Cookies do not appear to be enabled on your browser client. You will not be able to install the application with this feature disabled. Alternatively, there could also be a problem with the server's session.save_path. If this is the case, please consult your hosting provider if you don't know how to check or fix this yourself."

I know it's not a cookie problem. If I remember correctly, each clients' webroot (or perhaps root) should have a php.ini file that allows them to set the session.save_path as well as other variables for themselves, but I haven't been able to find the info that helped me solve this in the past.

Anyone?

Thanks!

Last edited by dc41; 18th November 2009 at 19:24. Reason: Clarity
Reply With Quote
  #4  
Old 18th November 2009, 19:42
dc41 dc41 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I changed the session.save_path setting in /etc/php.ini to /tmp. Now suPHP seems to be working fine.

But doesn't setting the path to something so public leave sessions open to hijacking? Is there a better setting than /tmp? Is it possible to put a variable in the path so that each client's site has its own session folder?

Thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing suPHP on centos 5.2 ISPconfig usul Installation/Configuration 11 27th October 2010 02:04
suPHP & Joomla SamTzu Installation/Configuration 13 16th October 2009 14:40
suPHP, Joomla! 1.5, file & diretory permissions pjdevries Installation/Configuration 17 19th June 2008 02:58
Joomla + suPHP + ispconfig + Etch causes too many processes! Insane1 HOWTO-Related Questions 4 11th May 2008 17:51
chrooted ISPConfig with suPHP & Joomla phpmail settings. SamTzu Installation/Configuration 14 6th May 2007 11:54


All times are GMT +2. The time now is 19:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.