Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th November 2009, 20:12
i_will3 i_will3 is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix not delivering outcoming mails.

Hello everybody,

I 've been using Postfix there has been while and I got a complication I can't work out...

I use fedora core 8 and here is my problem:

It started yesterday after I installed postfixadmin ,for every virtual domain I host I can't anymore receive any mail from yahoo or hotmail even gmail but I can send with no problem.

Here is what I get with postconf -n:
*--------------------------------------------*
alias_maps = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
header_checks = regexp:/etc/postfix/header_checks
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailbox_command = /usr/bin/procmail
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mydomain = domain.tld
myhostname = mail.domain.tld
mynetworks = 196.2.0.0/16, 127.0.0.0/8
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.6/README_FILES
relayhost = [cni.cbinf.com]
sample_directory = /usr/share/doc/postfix-2.3.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
unknown_local_recipient_reject_code = 550
virtual_alias_domains = likob.bi
virtual_alias_maps = hash:/etc/postfix/virtual
*-------------------------------------------------------------*

Here is what I get from my mail log in /var/log/maillog when I try to send an email to a one of the virtual domain hosted on my server

NOQUEUE: reject: RCPT from ey-out-1920.google.com[74.125.78.150]: 554 5.7.1 <kobe@virtualdomain.tld>: Relay access denied; from=<kobe@gmail.com> to=<kobe@domain.tld> proto=ESMTP helo=<ey-out-1920.google.com>
Nov 17 19:38:47 mail postfix/smtpd[8757]: disconnect from ey-out-1920.google.com[74.125.78.150]


Any help ?
Reply With Quote
Sponsored Links
  #2  
Old 18th November 2009, 15:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

I guess virtualdomain.tld should be listed under virtual_alias_domains as well.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th November 2009, 07:55
i_will3 i_will3 is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

hello,

I finally came throughout this,it is something like what you say falko.

I also noticed that virtualdomain.tld and others domains weren't listed on what I was getting with postconf-n ,and I also guessed that the messages for likob.bi were well delivered.

In main.cf ,for every virtual domain I would like to host ,I was adding those lines:
virtual_alias_domains=domain.tld
virtual_alias_maps=hash:/etc/postfix/virtual

I changed this way by adding only these 2 lines:

virtual_alias_domains=hash:/etc/postfix/virtual_alias_domains
virtual_alias_maps=hash:/etc/postfix/virtual


and I created the file /etc/postfix/virtual_alias_domains
which is in this format (domain date) ,the date is not necessary.

domain1.tld 20091118
domain2.tld 20091118

Don't forget postmap hash:/etc/postfix/virtual_alias_domains and of course the postfix reload.

And it worked ,so from now on, every virtual domain I want to host I only add it in /etc/ postfix/virtual_alias_domains and I make the mappings in /etc/postfix/virtual ,followed with postmap.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 06:39
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 12:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 01:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.