Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2009, 11:27
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default mod_fcgid: can't apply process slot for ...

when i open my web site in then virtual host, i found the php file doesnt running.
and so i open the error log file,
mod_fcgid: can't apply process slot for...

i dont know why? many thanks!
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2009, 12:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Please post the complete error message from the error log. Is this a vserver?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd November 2009, 12:11
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

apache error log

[Mon Nov 02 15:31:40 2009] [warn] (13)Permission denied: mod_fcgid: spawn process /var/www/tiaotiao.la/web/test.php error
[Mon Nov 02 15:31:41 2009] [error] (13)Permission denied: mod_fcgid: couldn't bind unix domain socket /etc/httpd/logs/fcgidsock/2095.191

site error log

[Mon Nov 02 15:24:29 2009] [warn] mod_fcgid: can't apply process slot for /var/www/tiaotiao.la/web/test.php
[Mon Nov 02 15:26:31 2009] [warn] mod_fcgid: can't apply process slot for /var/www/tiaotiao.la/web/test.php
[Mon Nov 02 15:31:41 2009] [warn] mod_fcgid: can't apply process slot for /var/www/tiaotiao.la/web/test.php

this server have been installed in a vmware virtual machine.

centos 5.3 apache 2.2.14 php 5.2.11 mysql 5.1.40
Reply With Quote
  #4  
Old 2nd November 2009, 12:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Please check that you have selinux disabled as described in the centos perfect server manual.

http://www.howtoforge.com/perfect-se...ispconfig-3-p3
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 3rd November 2009, 02:28
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, and the now the contents of the selinux config file :
SELINUX=disabled

SELINUXTYPE=targeted

SETLOCALDEFS=0

but mod_fcgid still cant running .
Reply With Quote
  #6  
Old 3rd November 2009, 03:31
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

P.S.
i didnt found the rpm mod_fcgid via installation by yum.
so i had install mod_fcgid by make install:

wget http://jaist.dl.sourceforge.net/sour..._fcgid.2.2.tgz
tar zxvf mod_fcgid.2.2.tgz
cd mod_fcgid.2.2

vi makefile
top_dir = /usr/lib/httpd
:wq
make
make install
Reply With Quote
  #7  
Old 3rd November 2009, 14:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by bardo View Post
P.S.
i didnt found the rpm mod_fcgid via installation by yum.
Did you enable the RPMforge repository on your server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 9th November 2009, 07:41
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
Did you enable the RPMforge repository on your server?
thank u.

i had enabled the RPMforge repository on my server. but because httpd, php, mysql, versions are not default version. so i didnt found the rpm mod_fcgid via installation by yum.
so i had install mod_fcgid by make install.
finily i found that the problem is security of the directory.

P.S. i have install mod_fcgid using another RPM. and i found, in this way the config file is difrence to other way that installing via yum.

Last edited by bardo; 9th November 2009 at 07:44.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with my 'Perfect Server' chillifire Server Operation 3 6th January 2010 12:26
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 17:30
Apache not starting up after installing ispconfig3 jamesls Installation/Configuration 5 11th April 2009 18:08
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Apache stopped mccharlet General 6 15th August 2007 15:27


All times are GMT +2. The time now is 17:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.