Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th November 2009, 15:01
The General The General is offline
Member
 
Join Date: Apr 2006
Location: U.K
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default Remote MySQL connection problems

Hi Guys,

Here is a tester for you

I have a fresh ispconfig 3 install in a DMZ (ORANGE) with all ports required open and pointing directly to the ISPConfig server at my house.

I have written a program in visual basic to connect to a database on this server but i keep getting this error message when trying a connection using this program from a friends house.

"Cannot connect to database: Unable to connect to any of the specified MySQL hosts."

The Basics,
MySQL has been stopped and started
Port 3306 TCP is forwarded from my smoothwall box to the server in the DMZ
Remote Access is enabled for this database
My User name has been entered with the correct "client prefix" I.E "c1testuser"

Now, this is the stinger !

If i try to connect to this database from my "GREEN" subnet using this program at my house i get a connection using the servers 192.168.1.*** I.P Address.It seems any access to MySQL from the internet is resulting in no connection, and the error message above in blue! By the way he has also already installed on his pc the MySQL.DATA.DLL files for the connection.

I Also get the same error when replacing the 'local' IP address to my ISP static address from at my house. which is a pain if you program and use connection strings!!!!!!!

Any Ideas will be COOOL!
Reply With Quote
Sponsored Links
  #2  
Old 7th November 2009, 07:19
Doug G Doug G is offline
HowtoForge Supporter
 
Join Date: Apr 2008
Posts: 64
Thanks: 0
Thanked 8 Times in 5 Posts
Default

Something in your firewall or router must be blocking port 3306. Did you check that port 3306 is open in the ispconfig firewall?
__________________
=====
Doug G
=====
Reply With Quote
  #3  
Old 7th November 2009, 12:12
The General The General is offline
Member
 
Join Date: Apr 2006
Location: U.K
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

tcp 3306 is forwarded from the smoothwall firewall to server
udp 3306 is forwarded from the smoothwall firewall to the server

ISPConfig firewall says that 3306 TCP & UDP are unblocked
am i missing something or is there any other port that should be open for this ?


i am going to reinstall smoothwall (the firewall), and see if that makes a differance. i will report back

Thanks

Bill

Last edited by The General; 7th November 2009 at 12:14. Reason: adding addition information
Reply With Quote
  #4  
Old 7th November 2009, 12:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,418
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

Also make sure that you configured mysql to isten on all IP addresses and not just 127.0.0.1 in the my.cnf file.

You can check it with:

netstat -tap | grep mysql
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th November 2009, 15:20
The General The General is offline
Member
 
Join Date: Apr 2006
Location: U.K
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default User error !

My friend said "HE IS A NUMPTY" !!!

i thought my instructions were faultless to him on installing and using the mysql port test programme but obviously not !

When inputting the user name for the database he has been inserting "CL******" as a client prefix not "C1******" He has and i will appologise for waisting time on this forum and it just goes to prove that maybe we should pay a little more attention to what we are doing and not automaticly think it's an error with ISPConfig or a LINUX distro

Thanks and appologies again
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
Attacks on MTA dclardy Installation/Configuration 4 29th September 2009 16:50
Mail not working epicuniversal General 5 13th June 2009 08:24
debian etch courier pop3 issue docean Installation/Configuration 6 20th March 2008 15:38
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11


All times are GMT +2. The time now is 18:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.