Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th February 2010, 03:42
rbartz rbartz is offline
Member
 
Join Date: Apr 2006
Posts: 80
Thanks: 9
Thanked 6 Times in 5 Posts
Default WEBDAV directory and file ownership

Hello!

I have a perfect server setup, Fedora Core 10, ispconfig 2.

Enabling WEBDAV is no problem, except that in order for a WEBDAV client to be able to write to the "web/" directory, I have to chmod it to 0777. After creating pages there with a client, the pages are owned by root.apache.

Is that right or is something wrong in our setup?

The real problem at the end is that the website client cannot change the files using FTP, permission denied. At the same time, if the files already exist, then WEBDAV cannot work with them as they are owned by the website admin.group.

Do we need to run SUPHP in order for WEBDAV to use the website admin owner.group?

Thanks,

Richard
Reply With Quote
Sponsored Links
  #2  
Old 24th February 2010, 14:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

That's normal, and that's why you should either use FTP or WebDAV, not both at the same time.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 24th February 2010, 15:13
rbartz rbartz is offline
Member
 
Join Date: Apr 2006
Posts: 80
Thanks: 9
Thanked 6 Times in 5 Posts
 
Default

Thank you Falko. Makes sense. I appreciate the quick reply.

Richard
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 19:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.