#1  
Old 4th November 2009, 22:26
Kyman2008 Kyman2008 is offline
Junior Member
 
Join Date: Nov 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Need Help With SystemImager

Hey guys, I'm new to SystemImager and I'm having a little bit of trouble... Here's my setup: I have a headnode set up running Linux Fedora 11 64bit and it has a dhcpd server assigning IP addresses to 4 cluster nodes on my network. Two of these cluster nodes have Linux Fedora 11 64bit installed, various other software, and then SystemImager 4.0.2. One of my cluster nodes was custom partitioned prior to Linux being installed. The other was just partitioned automatically with the Linux installation. I have successfully made an image of each node and I'm trying to send them to my other two nodes (which have blank hard drives). Both nodes boot from the network properly, connect to my image server (which is also my headnode), and find the image just fine. It's the autoinstallation of the images is where the trouble is.

When systemimager tries to install the image with the custom partitions,
everything is fine until this point:

*The partitions are created*
....
mount sysfs /a/sys -t sysfs -o defaults || shellout
Quietly installing image...
df: /a/tmp: No such file or directory
df: /a/boot: No such file or directory
df: /a/var: No such file or directory
df: /a/share: No such file or directory

These last four lines are just reprinted to the screen over and over until the whole process finally fails, saying:

mount: can't find a/var in /etc/fstab or /etc/mtab



When systemimager tries to install the image with the automatic Linux partitioning, the image seems to install alright.

rsync -aHS --exclude=lost+found/ --exclude=/proc/* --numberic-ids 192.168.0.100: : quadnode/ /a/

but then I receive something similar to:

swapper: page allocation failure. order:0, mode:0x20

Call Trace:
<IRQ> [<ffffffff8020e0ee>] __alloc_pages+0x288/0x2a1
[<ffffffff80233114>] tcp_v4_do_rcv+0x26/0x290
[<ffffffff8024fb45>] cache_alloc_refill+0x23f/0x45e
[<ffffffff80298982>] __kmalloc+0x50/0x57
[<ffffffff80228233>] __alloc_skb+0x5a/0x133
[<ffffffff803a4a5d>] nv_alloc_rx_optimized+0x58/0x18c
[<ffffffff803a6e30>] nv_nic_irq_optimized+0x87/0x1d9
[<ffffffff8020f098>] handle_IRQ_event+0x25/0x53
[<ffffffff80210374>] __do_softirq+0x46/0x90
[<ffffffff8028ab8f>] handle_fasteoi_irq+0x5b/0x88
[<ffffffff8025d66e>] do_IRQ+0xd7/0x132
[<ffffffff8025ba07>] default_idle+0x0/0x3a
[<ffffffff802509f1>] ret_from_intr+0x0/0xa
<EOI> [<ffffffff8045e907>] udp_poll+0x0/0x128
[<ffffffff8025ba2d>] default_idle+0x26/0x3a
[<ffffffff8023e163>] cpu_idle+0x3d/0x5c
[<ffffffff805e58e9>] start_kernel+0x294/0x2a0
[<ffffffff805e5140>] _sinittext+0x140/0x144

Mem-info:
DMA per-cpu:
CPU 0: Hot: hi: 0, btch: 1 usd: 0 Cold: hi: 0, btch: 1 usd: 0
DMA32 per-cpu:
CPU 0: Hot: hi: 186, btch: 31 usd: 30 Cold: hi: 62, btch: 15 usd: 48
Active:170237 inactive:288513 dirty:24931 writeback:1 unstable:0
free:2537 slab:47109 mapped:7013 pagetables:1123 bounce:0
DMA free:8024kB min:28kB low:32kB high:40kB active:3096kB inactive:0kB present:11164kB pages_scanned:128 all_unreclaimable? no
lowmem_reserve[]: 0 2003 2003
DMA32 free:2124kB min:5712kB low:7140kB high:8568kB active:677852kB inactive:1154052kB present:2051184kB pages_scanned:0 all_unreclaimable? no
lowmem_reserve[]: 0 0 0
DMA: 0*4kB 1*8kB 1*16kB 0*32kB 1*64kB 0*128kB 1*256kB 1*512kB 1*1024kB 1*2048kB 1*4096kB = 8024kB
DMA32: 1*4kB 1*8kB 0*16kB 0*32kB 1*64kB 0*128kB 0*256kB 0*512kB 0*1024kB 1*2048kB 0*4096kB = 2124kB
Swap cache: add 188636, delete 61524, find 121/155, race 0+0
Free swap = 5101816kB
Total swap = 5855208kB
Free swap: 5101816kB
524000 pages of RAM
9148 reserved pages
177075 pages shared
127112 pages swap cached
swapper: page allocation failure. order:0, mode:0x20



Any help is greatly appreciated! Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2009, 15:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by Kyman2008 View Post
When systemimager tries to install the image with the custom partitions,
everything is fine until this point:

*The partitions are created*
....
mount sysfs /a/sys -t sysfs -o defaults || shellout
Quietly installing image...
df: /a/tmp: No such file or directory
df: /a/boot: No such file or directory
df: /a/var: No such file or directory
df: /a/share: No such file or directory

These last four lines are just reprinted to the screen over and over until the whole process finally fails, saying:

mount: can't find a/var in /etc/fstab or /etc/mtab
Are you trying to install the image to a virgin system, or is the hard drive already formatted?



Quote:
Originally Posted by Kyman2008 View Post
When systemimager tries to install the image with the automatic Linux partitioning, the image seems to install alright.

rsync -aHS --exclude=lost+found/ --exclude=/proc/* --numberic-ids 192.168.0.100: : quadnode/ /a/

but then I receive something similar to:

swapper: page allocation failure. order:0, mode:0x20

Call Trace:
<IRQ> [<ffffffff8020e0ee>] __alloc_pages+0x288/0x2a1
[<ffffffff80233114>] tcp_v4_do_rcv+0x26/0x290
[<ffffffff8024fb45>] cache_alloc_refill+0x23f/0x45e
[<ffffffff80298982>] __kmalloc+0x50/0x57
[<ffffffff80228233>] __alloc_skb+0x5a/0x133
[<ffffffff803a4a5d>] nv_alloc_rx_optimized+0x58/0x18c
[<ffffffff803a6e30>] nv_nic_irq_optimized+0x87/0x1d9
[<ffffffff8020f098>] handle_IRQ_event+0x25/0x53
[<ffffffff80210374>] __do_softirq+0x46/0x90
[<ffffffff8028ab8f>] handle_fasteoi_irq+0x5b/0x88
[<ffffffff8025d66e>] do_IRQ+0xd7/0x132
[<ffffffff8025ba07>] default_idle+0x0/0x3a
[<ffffffff802509f1>] ret_from_intr+0x0/0xa
<EOI> [<ffffffff8045e907>] udp_poll+0x0/0x128
[<ffffffff8025ba2d>] default_idle+0x26/0x3a
[<ffffffff8023e163>] cpu_idle+0x3d/0x5c
[<ffffffff805e58e9>] start_kernel+0x294/0x2a0
[<ffffffff805e5140>] _sinittext+0x140/0x144

Mem-info:
DMA per-cpu:
CPU 0: Hot: hi: 0, btch: 1 usd: 0 Cold: hi: 0, btch: 1 usd: 0
DMA32 per-cpu:
CPU 0: Hot: hi: 186, btch: 31 usd: 30 Cold: hi: 62, btch: 15 usd: 48
Active:170237 inactive:288513 dirty:24931 writeback:1 unstable:0
free:2537 slab:47109 mapped:7013 pagetables:1123 bounce:0
DMA free:8024kB min:28kB low:32kB high:40kB active:3096kB inactive:0kB present:11164kB pages_scanned:128 all_unreclaimable? no
lowmem_reserve[]: 0 2003 2003
DMA32 free:2124kB min:5712kB low:7140kB high:8568kB active:677852kB inactive:1154052kB present:2051184kB pages_scanned:0 all_unreclaimable? no
lowmem_reserve[]: 0 0 0
DMA: 0*4kB 1*8kB 1*16kB 0*32kB 1*64kB 0*128kB 1*256kB 1*512kB 1*1024kB 1*2048kB 1*4096kB = 8024kB
DMA32: 1*4kB 1*8kB 0*16kB 0*32kB 1*64kB 0*128kB 0*256kB 0*512kB 0*1024kB 1*2048kB 0*4096kB = 2124kB
Swap cache: add 188636, delete 61524, find 121/155, race 0+0
Free swap = 5101816kB
Total swap = 5855208kB
Free swap: 5101816kB
524000 pages of RAM
9148 reserved pages
177075 pages shared
127112 pages swap cached
swapper: page allocation failure. order:0, mode:0x20
I guess this is nothing to worry about. Can you boot the system afterwards?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Systemimager Error When Autoinstall asyadiqin HOWTO-Related Questions 8 31st January 2009 13:09
Ubuntu 8.04 and systemimager cortexx HOWTO-Related Questions 7 18th November 2008 18:21
SystemImager Problem hanzam HOWTO-Related Questions 7 14th June 2007 20:57
systemimager and windows partition lokida Installation/Configuration 3 12th December 2006 13:53
systemimager: no hda found pregs HOWTO-Related Questions 3 12th October 2006 18:02


All times are GMT +2. The time now is 12:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.