Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th November 2009, 10:14
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Question "It works!" and Ubuntu 9.10

Greetings,

I have an issue I ran into before, but can't find the old posts I had. I also have a twist.

The problem is that when I have everything configured, my site http://demortes.hopto.org still gives the default page for apache2 installation. The "It works!" followed by "This is the default web page for this server." and on a new line, "The web server software is running but no content has been added, yet."

To explain what I've done, I'll need to explain my network setup as well. ISPConfig 2 is installed on a VMWare Server, through Windows 7 as the host machine. The "guest" is an Ubuntu 9.10 server, no GUI components installed. I followed a guide The Perfect Server - Ubuntu Karmic Koala (Ubuntu 9.10) [ISPConfig 2] (source here). This is all behind a NAT Linksys WRT54GS2 router with the ports forwarded.

Before installing the ISPConfig through the installer I installed the suPHP according to the Ubuntu section here. I did download the latest, as the one listed there didn't compile. Everything else I configured and compiled just as stated there.

With the above information, you realize by now I have two IP addresses to consider. My 192.169 and my external. Since any nslookup can give that IP address out, that would be 69.92.132.200.

I restored a working backup of the ispconfig database, but it seems to not be working now. I would like to confirm, and if needed, get further help on locating what is going wrong and why I'm not getting the ISPConfig page stating it's hosted and the default for ISPConfig, instead of the "It works".

Now the servers IP address in Management -> Server -> Settings is currently set to my 192.168 address. Everything dependent on that is set as well, the co-domain IP, etc. The DNS is set as that as well, since the hopto.org does not rely on my DNS server for it. The IP address does not give me the sharedip either.

What do I need to look at to see why ISPConfig's vhost is not taking over vs the /var/www/index.html

After realizing to myself what the problem might be, I checked the /etc/apache2/vhosts/Vhosts_ispconfig.conf file, and it's blank.

Thank you for your help, I look forward to receiving the great help I see here all the time. Accept my apologies if this has been covered elsewhere.

Demortes
Kevin Dethlefs-Moreno

P.S. Of course, if you need more information or pastes from actual files, please let me know.
Reply With Quote
Sponsored Links
  #2  
Old 10th November 2009, 10:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=33219
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
demortes (10th November 2009)
  #3  
Old 10th November 2009, 10:24
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default

Thanks for the quick reply.

What I have taken from the post is to move the Vhosts backup, and check syntax.

I received the following:

root@demortes:/etc/apache2/vhosts# mv Vhosts_ispconfig.conf vhosts_ispconfig.conf.bak
root@demortes:/etc/apache2/vhosts# mv Vhosts_ispconfig.conf_10-11-09_02-31-19 Vhosts_ispconfig.conf
root@demortes:/etc/apache2/vhosts# httpd -t
httpd: bad user name ${APACHE_RUN_USER}
Reply With Quote
  #4  
Old 10th November 2009, 10:27
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default

Also, looking into it further, I found it needed envvars, which contain:

# envvars - default environment variables for apache2ctl

# Since there is no sane way to get the parsed apache2 config in scripts, some
# settings are defined via environment variables and then used in apache2ctl,
# /etc/init.d/apache2, /etc/logrotate.d/apache2, etc.
export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data
export APACHE_PID_FILE=/var/run/apache2.pid

## The locale used by some modules like mod_dav
export LANG=C
## Uncomment the following line to use the system default locale instead:
#. /etc/default/locale

export LANG
Reply With Quote
  #5  
Old 10th November 2009, 10:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

For ubuntu, use thsi for testing:

http://www.howtoforge.com/forums/sho...0&postcount=31
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
demortes (10th November 2009)
  #6  
Old 10th November 2009, 10:34
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default

Syntax error on line 36 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration

Looking deeper into this, it seems its because I disabled PHP5 and allowed suPHP globally.

How should I have done this, if not done by the guide on this site?
Reply With Quote
  #7  
Old 10th November 2009, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

You have to enable suphp in the ispconfig config.inc.php file. See first steps guide for details.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
demortes (10th November 2009)
  #8  
Old 10th November 2009, 10:44
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
Default

a2enmod php5 gave me some results.

The sharedip vhost now comes up for my demortes.hopto.org url.

What am I missing?
Reply With Quote
  #9  
Old 10th November 2009, 10:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

See my post above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
demortes (10th November 2009)
  #10  
Old 10th November 2009, 10:56
demortes demortes is offline
Member
 
Join Date: Mar 2007
Posts: 71
Thanks: 6
Thanked 1 Time in 1 Post
 
Default

I got it to work. Thanks for pointing me in the right direction Till.
Reply With Quote
Reply

Bookmarks

Tags
configuration, nat, request for assistance, suphp, ubuntu 9.10

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users and Domains howto and the ISPConfig3 howto for Ubuntu 9.10 loubart HOWTO-Related Questions 9 2nd December 2009 15:58
Missing Proftpd after Ubuntu 9.10 Upgrade (ISPConfig 2 Perfect Server) dwtj01 HOWTO-Related Questions 0 31st October 2009 04:02
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
Problem on restart bind9 satimis Server Operation 6 30th October 2007 02:01
Log for Debugging jwan Installation/Configuration 5 27th October 2006 14:34


All times are GMT +2. The time now is 18:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.