Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd February 2010, 12:53
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default Access denied for user 'ispconfig'@'localhost'

Hello and good morning.
I have backed up and restored ISPConfig 3 to a new machine but for some reason I can not load the sites. I keep getting an error of " Access denied for user 'ispconfig'@'localhost'" either in the logs or when I try to access this ispconfig user via mysql -u ispconfig -p to confirm valid access.

Also when attempting to restart mydns I get the following:
"Starting mydns mydns[9259]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES) (errno=0)
startproc: exit status of parent of /usr/sbin/mydns: 1"

So I am assuming there is something going on with ISPConfig trying to access mysql. The ispconfig password that I have has non standard characters in it but this has never been a problem on the previous machine, or the machine before that. The two machines before this were identical in hardware so upon restore of the previous machine, I just copied all directories and files over and it worked. Since this new machine is different, I am faced with a more complex problem.

Also, when restarting apache, I am getting virtual host messages stating:

[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Feb 02 02:56:36 2010] [warn] VirtualHost XXX.XXX.X.X:80 overlaps with VirtualHost XXX.XXX.X.X:80, the first has precedence, perhaps you need a
NameVirtualHost directive

Before this, apache would fail because the /usr/local/ispconfig/server/scripts/vlogger folder was not there. I copied this over and now it restarts, ispconfig cpanel comes up but no sites.

Can someone help me with this? I have been at my wits end for a few days now.

Thanks!

Ray
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3

Last edited by reason8; 2nd February 2010 at 13:00. Reason: virtualhost message
Reply With Quote
Sponsored Links
  #2  
Old 3rd February 2010, 15:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are there any MySQL errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th February 2010, 12:19
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Are there any MySQL errors in your logs?
I am getting mydns errors in /var/log/messages:
Feb 4 02:01:26 isp mydns[12596]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES
) (errno=0)

/var/log/mysqld.log lookgs good.
100204 01:55:44 mysqld ended

100204 01:55:44 mysqld started
100204 1:55:44 InnoDB: Started; log sequence number 0 43665
100204 1:55:44 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.0.67' socket: '/var/lib/mysql/mysql.sock' port: 3306 SUSE MySQL RPM
/var/log/mysqld.log lines 20-42/42 (END)

BTW, I just removed mysql and mysq-client and deleted my backups of mysql logs from previous install. The above reflects that current state.
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
  #4  
Old 4th February 2010, 12:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,717
Thanks: 840
Thanked 5,593 Times in 4,404 Posts
Default

The reson for the error messages is that the password of the ispconfuig mysql database user ahs been changed or that the ispconfig mysql database user has been removed. To repair the setup, download ispconfig 3.0.1.6 and run the update.php script and choose to reconfigure the services when the updater asksk you.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th February 2010, 12:15
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
The reson for the error messages is that the password of the ispconfuig mysql database user ahs been changed or that the ispconfig mysql database user has been removed. To repair the setup, download ispconfig 3.0.1.6 and run the update.php script and choose to reconfigure the services when the updater asksk you.
The backup version of ISPConfig 3 is 3.0.1.6. After a restore the command "ispconfig_update.sh" will not work because 3.0.1.6 is already on this system. The response I get is "There are no updates available for ISPConfig 3.0.1.6"

This is after I copy my backup /var/lib/mysql to the new server. Also, mydns will not load. It gives me an error of:

Starting mydns mydns[5438]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES) (errno=0)
startproc: exit status of parent of /usr/sbin/mydns: 1
failed


The problem is when I try to restore mysql database for the webserver. I can not login to the control panel either. I am assuming because it is not able to read the information stored in mysql database.

Thanks!
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
  #6  
Old 7th February 2010, 17:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,717
Thanks: 840
Thanked 5,593 Times in 4,404 Posts
Default

Use the manual update procedure as described in the release notes:

http://www.howtoforge.com/forums/showthread.php?t=40183
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 8th February 2010, 02:22
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Use the manual update procedure as described in the release notes:

http://www.howtoforge.com/forums/showthread.php?t=40183
That did not work. It will not allow me to login to the control panel. I am still getting mydns errors that the ispconfig user does not have access to the mysql user database.

Maybe I am not understanding the exact process of restoring ISPConfig 3. Can you detail it for me. What needs to be restored and installed and in what order.

Thanks!
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
  #8  
Old 13th February 2010, 04:17
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Use the manual update procedure as described in the release notes:

http://www.howtoforge.com/forums/showthread.php?t=40183
Hello. I was wondering if you had any insight on this situation. For the life of me I can not figure out how to get mydns to connect to ispconfig mysql database with the ispconfig username that I am trying to restore to a new server. Any help would be appreciated.

Thanks.
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
  #9  
Old 25th February 2010, 21:18
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Well I have come to the conclusion that there is something in the /etc folder that is needed to start mydns successfully. I am not sure what it is but am in the process of investigating this. I know it's the /etc folder because a restored the production /etc folder to the test /etc folder and mydns worked in addition to mysql and the ispconfig loading.

Anyone have input into which file(s) is needed to bring up mydns?
__________________
Running:

ISPConfig 3
openSUSE Linux 11.3
Reply With Quote
  #10  
Old 26th February 2010, 01:06
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
 
Default

/etc/mydns.conf is needed.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
The Following User Says Thank You to BorderAmigos For This Useful Post:
reason8 (28th February 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 and Apache problems K_meleonu Server Operation 1 9th July 2009 11:13
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 14:06
Apache Ownership cybereatl General 2 26th March 2008 13:25
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 19:26


All times are GMT +2. The time now is 02:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.