Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2009, 14:15
foottuns foottuns is offline
Junior Member
 
Join Date: Apr 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default ns installation wont let me do it on ubuntu 9.10

Helllo there, I don't know if here is the place but I am trying to configure ns on my system, I saw a few tutorials which they were interested and good, but all the time when I try to compile the ns source I get this error and I don't know what should I do to fix it.

Error

Code:

Code:
checking for a BSD-compatible install... /usr/bin/install -c
checking system version (for dynamic loading)... Linux-2.6.31-14-generic
No explicit static compilation flag; setting V_STATIC to ""
checking for dlopen in -ldl... yes
checking for a BSD-compatible install... /usr/bin/install -c
configure: creating ./config.status
config.status: creating Makefile
rm -f libotcl.so otcl.o so_locations
gcc -c -g -O2 -DNDEBUG -DUSE_SHM -fpic -I. -I/home/bogdan/ns/ns-allinone-2.34/include -I/home/bogdan/ns/ns-allinone-2.34/include -I/home/bogdan/ns/ns-allinone-2.34/include -I/include  otcl.c
ld -shared -o libotcl.so otcl.o
otcl.o: In function `OTclDispatch':
/home/bogdan/ns/ns-allinone-2.34/otcl-1.13/otcl.c:495: undefined reference to `__stack_chk_fail_local'
otcl.o: In function `Otcl_Init':
/home/bogdan/ns/ns-allinone-2.34/otcl-1.13/otcl.c:2284: undefined reference to `__stack_chk_fail_local'
ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Nonrepresentable section on output
make: *** [libotcl.so] Error 1
otcl-1.13 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2009, 14:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

As far as I can see, the compile output you posted is not from mydns and mydns is currently the only supported dns server of ispconfig 3 stable versions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd November 2009, 22:48
foottuns foottuns is offline
Junior Member
 
Join Date: Apr 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the problem has been sort it out, now is working perfectly, soon i will write a tutorial how i did it and i will add it here....
Reply With Quote
  #4  
Old 5th November 2009, 13:57
pdro7 pdro7 is offline
Junior Member
 
Join Date: Nov 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default otcl problem on ubunto 9.X

foottuns how did u resolve the problem?? i'm having it now =(
Reply With Quote
  #5  
Old 8th January 2010, 06:49
LakeEffect LakeEffect is offline
Junior Member
 
Join Date: Jan 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default otcl problem on ubuntu 9.10

This error is because the linker being used is "ld -shared" instead of "gcc -shared". If you edit one line in otcl-1.1*/configure, and rerun install, it should work:

--- configure.orig 2009-11-02 12:14:52.556167945 -0800
+++ configure 2009-11-02 12:17:28.966706099 -0800
@@ -6301,7 +6301,7 @@
;;
Linux*)
SHLIB_CFLAGS="-fpic"
- SHLIB_LD="ld -shared"
+ SHLIB_LD="gcc -shared"
SHLIB_SUFFIX=".so"
DL_LIBS="-ldl"
SHLD_FLAGS=""
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 14:49
installation on ubuntu 8.10 intrepid ibex Balbuzard Installation/Configuration 15 28th March 2009 19:58
Ubuntu 8.04 server edition ISPconfig installation error malinens Installation/Configuration 4 30th July 2008 08:30
Problem on restart bind9 satimis Server Operation 6 30th October 2007 03:01
Perfect Ubuntu Installation Problems zimele HOWTO-Related Questions 5 13th June 2006 12:24


All times are GMT +2. The time now is 02:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.