#1  
Old 1st December 2009, 21:40
mc2mac mc2mac is offline
Junior Member
 
Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default GlusterFS write issue

Hi,

I am following excellent tutorial re High-Availability Storage With GlusterFS On Debian Lenny

it works great, I can touch files and they replicate, syncs off line servers and so on...

so, operations like:

touch /mnt/glusterfs/test3
touch /mnt/glusterfs/test4
rm -f /mnt/glusterfs/test2

no problem.

but I can't actually move, copy or rsync any files to /mnt/glusterfs/

this is what I get:

mc2mac@Client1:/mnt/glusterfs$ cp /tmp/file1.tar.gz /mnt/glusterfs/
cp: writing `/mnt/glusterfs/file1.tar.gz': Transport endpoint is not connected
cp: closing `/mnt/glusterfs/file1.tar.gz': Transport endpoint is not connected

it's makes the whole setup ubusable. I need to run

/etc/init.d/glusterfsd restart

on each of the data servers to get it back up and running.

I am using Ubuntu 9.10 32 bit server edition all on Virtual Boxes instances.

Would really appreciate some pointers, as I need to deploy it soon...


Mc2Mac

Last edited by mc2mac; 1st December 2009 at 21:43.
Reply With Quote
Sponsored Links
  #2  
Old 2nd December 2009, 16:04
mc2mac mc2mac is offline
Junior Member
 
Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default solved (?)

I have reinstalled everything using the exact versions used in the tutorial and it works.

Foolishly tought that there is not much difference between glusterfs 2.0.1 and 2.07

thanx for great tutorial
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mail stop on one account provell General 10 26th November 2009 22:29
LB1 Not Taking Over Shared IP Using Heartbeat 2.1.3 On FC10 64Bit asyadiqin Installation/Configuration 5 11th February 2009 21:11
ISPConfig Installation error linuxuser1 Installation/Configuration 4 26th February 2008 07:38
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 17:05
ISPConfig 2.2.10 released till General 70 7th March 2007 19:25


All times are GMT +2. The time now is 11:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.