Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2009, 10:52
loge loge is offline
Junior Member
 
Join Date: Nov 2007
Posts: 21
Thanks: 1
Thanked 1 Time in 1 Post
Default (ISP3) Error: configuration file /etc/getmail/*.conf does not exist

This is what i get when i look in the "ISPConfig Cron Log":

Error: configuration file /etc/getmail/*.conf does not exist
Error: configuration file /etc/getmail/*.conf does not exist
Error: configuration file /etc/getmail/*.conf does not exist
Error: configuration file /etc/getmail/*.conf does not exist
Error: configuration file /etc/getmail/*.conf does not exist
....


I followed the "Perfect Setup on lenny". Everything else works like a charm up until now.. but this one looks ugly....

Thanks for infos....

Marc
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2009, 12:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

Thats absolutely ok and not an error. This message pppaers when no fetchmail job exists.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th March 2009, 02:51
elchequimbiri elchequimbiri is offline
Junior Member
 
Join Date: Mar 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default In ISPconfig 3.0.0.1 getmail does not work

Hello

I am moving to a new server and I want to retrive mail via fetchmail.

I followed the Perfect Setup on lenny and install first the ISPConfig-3.0.1.tar.gz and the svn version. The same errors in both cases.

I have this errors when I run /usr/local/ispconfig/server/scripts/run-getmail.sh

Delivery error (command sendmail 23965 error (127, exec of command sendmail failed (refuse to invoke external commands as root or GID 0 by default)))
msg 1/34 (15499 bytes), delivery error (command sendmail 23965 error (127, exec of command sendmail failed (refuse to invoke external commands as root or GID 0 by default)))

And in
In /var/log/ispconfig/cron.log

Error: unknown argument(s) ['/etc/getmail/mail.***.com_user@***.com.conf'] ; try --help


Any sugestions?

Thanks,
Elche

Last edited by elchequimbiri; 27th March 2009 at 02:59.
Reply With Quote
  #4  
Old 27th March 2009, 15:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,714 Times in 2,556 Posts
Default

This has been fixed in SVN already. We will release an update next week.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th June 2009, 02:54
dragons dragons is offline
Junior Member
 
Join Date: Mar 2009
Posts: 18
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I am also getting this error with ISPConfig0.0.1.3 and getmail-4.9.0-1.el5.rf.noarch on CentOS 5.3, is there a way to make it happy and stop the error?
Reply With Quote
  #6  
Old 10th June 2009, 07:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

This is not an error. This message just means that you did not create a fetchmail account yet on your system.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
dragons (10th June 2009)
  #7  
Old 21st June 2009, 22:49
wouterw wouterw is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello,

/usr/local/bin/run-getmail.sh
Error: configuration file /etc/getmail/*.conf does not exist

I'm getting this same errors in ISPC Cron Log. I have multiple mailboxes configured. Problem is that I do not recieve any mail.

I upgraded to 3.0.1.3 today and reconfigured the services. I'm running on CentOS 5.3.

Thanks in advance,

Wouter

Last edited by wouterw; 21st June 2009 at 22:54.
Reply With Quote
  #8  
Old 22nd June 2009, 11:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

Please see #2 in this thread.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 22nd June 2009, 11:53
wouterw wouterw is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
Please see #2 in this thread.
Ok, thank you.

Could you tell me why I do not receive any mail then? Some entries are on the filesystem in for example /var/spool/postfix/deferred/2/24EA014F02FB. This mail does not show up in my IMAP mailbox however.
Reply With Quote
  #10  
Old 22nd June 2009, 14:23
wouterw wouterw is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

ok, I found these errors in the mail log:

Code:
Jun 22 12:59:02 s1279 postfix/qmgr[3495]: 0D51814F0340: to=<root@***.nxs.nl>, relay=none, delay=47590, delays=47590/0.05/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 22 12:59:02 s1279 postfix/qmgr[3495]: EE12314F0342: to=<root@***.nxs.nl>, relay=none, delay=47290, delays=47290/0.05/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 22 12:59:02 s1279 postfix/qmgr[3495]: 4918A14F034C: to=<root@***.nxs.nl>, relay=none, delay=35891, delays=35891/0.05/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 22 12:59:02 s1279 postfix/qmgr[3495]: 388DE14F02F0: to=<wouter@***.com>, relay=none, delay=56302, delays=56302/0.06/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 22 12:59:02 s1279 postfix/qmgr[3495]: 9262A14F0466: to=<***@***.nl>, relay=none, delay=1962, delays=1962/0.07/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)
Jun 22 12:59:02 s1279 postfix/qmgr[3495]: 96EEA14F031C: to=<***@***.nl>, relay=none, delay=55789, delays=55789/0.07/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]: Connection refused)

..

Jun 22 13:03:11 s1279 imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 22 13:03:11 s1279 imapd: LOGIN, user=wouter@***.com, ip=[::ffff:127.0.0.1], port=[52123], protocol=IMAP
Jun 22 13:03:11 s1279 imapd: LOGOUT, user=wouter@***.com, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=87, sent=391, time=0
Jun 22 13:03:31 s1279 postfix/smtpd[25663]: connect from bb121-6-40-42.singnet.com.sg[121.6.40.42]
Jun 22 13:03:34 s1279 postfix/smtpd[25663]: NOQUEUE: reject: RCPT from bb121-6-40-42.singnet.com.sg[121.6.40.42]: 554 5.7.1 <citymgr@gtcom.nl>: Relay access denied; from=<soniat@baptiststandard.com> to=<citymgr@gtcom.nl> proto=ESMTP helo=<bb121-6-40-42.singnet.com.sg>
Someone got any clue?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rewrite url not work apache2+mod_rewrite mohamedtah Installation/Configuration 1 31st January 2009 13:00
Dspam planet_fox General 6 20th January 2007 18:42
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 16:12
/stats doesn't work (password not accepted) Hellbound General 6 15th September 2005 15:34


All times are GMT +2. The time now is 06:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.