Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th October 2009, 12:05
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache2 show error on mixing * ports and non-* ports

I add :80 as suggested at: http://bugtracker.ispconfig.org/inde...ls&task_id=672

But I still receive the same error with :80 added:

[error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
Reply With Quote
Sponsored Links
  #2  
Old 31st October 2009, 13:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st October 2009, 14:42
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ubuntu 64bit Server Edition
Reply With Quote
  #4  
Old 1st November 2009, 16:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's in /etc/apache2/ports.conf and /etc/apache2/sites-available/default?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd November 2009, 04:19
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ports.conf

Listen 80

<IfModule mod_ssl.c>
Listen 443
</IfModule>

default

NameVirtualHost *
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/*/web>
Options +Includes -Indexes FollowSymLinks MultiViews
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>
Reply With Quote
  #6  
Old 3rd November 2009, 11:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Change the line:

NameVirtualHost *

to:

NameVirtualHost *:80

and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 4th November 2009, 02:13
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No use. Still show error 403 instead of listing the files...
Reply With Quote
  #8  
Old 4th November 2009, 08:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Post the exact error message from the apache error log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 5th November 2009, 09:09
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have post the error log at another thread with similar problem:

http://www.howtoforge.com/forums/sho...ight=error+log
Reply With Quote
  #10  
Old 6th November 2009, 15:00
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Please let me know which folder can I find this apache2 error log?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.