Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st March 2008, 13:38
davidcampbell davidcampbell is offline
Junior Member
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy ISPConfig .htaccess Options +Indexes

I have a Debian Etch 4.0r2 running the latest version of ISPConfig (installed last weekend) + phpmyadmin module addon

I'm having an issue with allowing Directory Indexes, all the apache servers I've worked with before (I'll admit, Im fairly noob-ish ) have just let me add a .htaccess file in the directory and add the lines

Options +Indexes
IndexOptions +FancyIndexing

And that will make my indexing work, but in ISPConfig I get a 500 Internal Server Error page coming up... can somebody help me
Reply With Quote
Sponsored Links
  #2  
Old 22nd March 2008, 00:00
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

Not sure if this is the safest way, but I added this to the apache directives feild for the site that I wanted to have indexed.
Code:
<Directory /path/to/dir>
    Options +Includes +Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
Reply With Quote
  #3  
Old 22nd March 2008, 09:37
davidcampbell davidcampbell is offline
Junior Member
 
Join Date: Jan 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks alot, that works nicely... but can I ask, is there anyway to allow this to work directly with .htaccess files?
Reply With Quote
  #4  
Old 22nd March 2008, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

At the end of /etc/apache2/apache2.conf, you should find something like this:

Code:
<Directory /var/www/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
You can adjust that to your likings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th October 2009, 04:35
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Is this file located under /etc/apache2/sites-enabled/000-default?

And do I have to restart apache after editing this for it to take effect?
Reply With Quote
  #6  
Old 29th October 2009, 04:56
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache2 show error on mixing * ports and non-* ports

I add :80 as suggested at: http://bugtracker.ispconfig.org/inde...ls&task_id=672

But I still receive the same error with :80 added:

[error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
Reply With Quote
  #7  
Old 29th October 2009, 22:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by bhwong View Post
Is this file located under /etc/apache2/sites-enabled/000-default?

And do I have to restart apache after editing this for it to take effect?
Do you use ISPConfig 2 or 3?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 30th October 2009, 02:05
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I use ISPConfig3
Reply With Quote
  #9  
Old 30th October 2009, 08:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Then your're in the wrong forum. This thread and Forum is about ISPConfig 2, which is a completely different doftware then ISPConfig 3 and everything that is posted here does not apply to your installation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 30th October 2009, 12:05
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Oh, so sorry. I will repost this to the correct forum.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig, Drupal, and .htaccess jon335 General 23 16th November 2008 13:22
SSL VIrtual host overlap? HELP terryoleary1981 Installation/Configuration 20 31st January 2008 23:53
.htaccess and Options All -Indexes edge General 7 12th November 2007 12:53
ISPConfig 2.2.13 released till General 35 23rd July 2007 16:28
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46


All times are GMT +2. The time now is 09:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.