Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th October 2009, 10:08
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default How to get files stored in web folder listed in the web browser

.htaccess indexes usually get files listed on web browser. But both .htaccess and amendment at apache2 to list file failed. How to do I get this done with ISPConfig? If ISPConfig interface do not support this, is it possible to do it in the terminal?
Reply With Quote
Sponsored Links
  #2  
Old 28th October 2009, 16:05
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

You can add this either in the .htaccess file or in the apache directives field of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th October 2009, 16:20
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

As mentioned above, I tried both .htaccess and apache directive. Both do not have any effect on the webpage running from ISPConfig.
Reply With Quote
  #4  
Old 28th October 2009, 19:15
Doug G Doug G is offline
HowtoForge Supporter
 
Join Date: Apr 2008
Posts: 67
Thanks: 0
Thanked 8 Times in 5 Posts
Default

Quote:
Originally Posted by bhwong View Post
As mentioned above, I tried both .htaccess and apache directive. Both do not have any effect on the webpage running from ISPConfig.
Double-check for any typos and review the log files for any errors. I added directory indexes from an apache directive in ispconfig without any problem.
__________________
=====
Doug G
=====
Reply With Quote
  #5  
Old 29th October 2009, 03:58
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Please tell me where I did wrong.

I create .htaccess with "Options +Indexes" as it's content and place in the [web] folder. Get Error 403.

I add the following content in /etc/apache/httpd.conf:

<Directory />
allow from all
Options +Indexes
Allowoverride All
</Directory>

Still get Error 403.
Reply With Quote
  #6  
Old 29th October 2009, 08:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Whic is the exact error message that gets logged in the error.log of the website?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 30th October 2009, 02:34
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
Default

The error log show:

Client denied by Server Configuration: /var/www/www.xxx.com/web/public/index.php

But when I access this folder using a FTP Client, I do not see it. I also notice that when I put a .htaccess file, it will disappear too. I have edit the conf not to hide .ht* but it has no effect just as the directive to list files.
Reply With Quote
  #8  
Old 30th October 2009, 03:24
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

If you are using pure-ftpd, you have to add a file in the configuration to show the files that start with a dot.

This is from a comment on one of the Perfect Server tutorials.

To make PureFTPD show hidden files you have to create a new file "DisplayDotFiles" in "/etc/pure-ftpd/conf/" with the value "yes".

That should show you the .htaccess file in the ftp client.
Reply With Quote
  #9  
Old 30th October 2009, 08:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by bhwong View Post
The error log show:

Client denied by Server Configuration: /var/www/www.xxx.com/web/public/index.php

But when I access this folder using a FTP Client, I do not see it. I also notice that when I put a .htaccess file, it will disappear too. I have edit the conf not to hide .ht* but it has no effect just as the directive to list files.
Please run the following command as root user on the shell and post the output:

ls -la /var/www/www.xxx.com/web/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 30th October 2009, 12:19
bhwong bhwong is offline
Member
 
Join Date: Oct 2009
Posts: 42
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to export files from virtual machine to home folder? oliverb4ss Technical 6 18th May 2007 18:38
Default Web Dir fro Installation/Configuration 1 21st October 2006 12:03
uploaded web files not accessable DTGorm General 3 30th May 2006 00:50
web folder wadims Installation/Configuration 1 26th April 2006 09:29
FTP access to web files in ISPConfig Rocky Installation/Configuration 14 8th November 2005 23:17


All times are GMT +2. The time now is 14:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.