Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th October 2009, 19:58
AsDsL AsDsL is offline
Member
 
Join Date: Jul 2007
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Default Pure-ftpd Login Problem

Hi,
After upgrade to ISPConfig 3.0.1.6, I cant login into ftp server.

Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Error: Could not connect to server

How may I fix it/
Thanks1
tony
Reply With Quote
Sponsored Links
  #2  
Old 27th October 2009, 08:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Which Linux distribution?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th October 2009, 14:39
AsDsL AsDsL is offline
Member
 
Join Date: Jul 2007
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ubuntu 9.04
Reply With Quote
  #4  
Old 28th October 2009, 00:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's the output of
Code:
netstat -tap
? Any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd November 2009, 19:09
ilja ilja is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have the same problem,

netstat -tap gives

================
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:35362 *:* LISTEN 2759/rpc.statd
tcp 0 0 localhost:10024 *:* LISTEN 2927/amavisd (maste
tcp 0 0 localhost:10025 *:* LISTEN 3570/master
tcp 0 0 *:mysql *:* LISTEN 2991/mysqld
tcp 0 0 localhost:spamd *:* LISTEN 3062/spamd.pid
tcp 0 0 *:sunrpc *:* LISTEN 2748/portmap
tcp 0 0 10.150.1.2:domain *:* LISTEN 3498/mydns
tcp 0 0 localhost:domain *:* LISTEN 3498/mydns
tcp 0 0 localhost:822 *:* LISTEN 3614/famd
tcp 0 0 *:ssh *:* LISTEN 2898/sshd
tcp 0 0 *:smtp *:* LISTEN 3570/master
tcp 0 0 10.150.1.2:43993 villa.debian.org:www TIME_WAIT -
tcp 0 0 localhost:53764 localhost:www TIME_WAIT -
tcp 0 0 10.150.1.2:56977 unassigned-92.colo.:www TIME_WAIT -
tcp 0 0 localhost:59445 localhost:domain TIME_WAIT -
tcp 0 0 10.150.1.2:34168 kassia4.snt.utwente:www TIME_WAIT -
tcp 55 0 localhost:39470 localhost:10025 CLOSE_WAIT 3434/amavisd (ch1-a
tcp 0 288 10.150.1.2:ssh 10.150.6.10:51168 ESTABLISHED 25070/sshd: ilja [p
tcp 0 0 10.150.1.2:53838 ftp.belnet.be:www TIME_WAIT -
tcp6 0 0 [::]:imaps [::]:* LISTEN 3470/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 3493/couriertcpd
tcp6 0 0 [::]op3 [::]:* LISTEN 3481/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 3458/couriertcpd
tcp6 0 0 [::]:http-alt [::]:* LISTEN 3675/apache2
tcp6 0 0 [::]:www [::]:* LISTEN 3675/apache2
tcp6 0 0 localhost:domain [::]:* LISTEN 3498/mydns
tcp6 0 0 [::]:ssh [::]:* LISTEN 2898/sshd
tcp6 0 0 [::]:https [::]:* LISTEN 3675/apache2
==========


So it's not listening on port 21.
pure-ftpd-control start doesn't do anything. There's no obvious errors in any logs, no mention of pureftp in syslog or messages...
Reply With Quote
  #6  
Old 23rd November 2009, 19:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Is this a vserver?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 23rd November 2009, 19:36
ilja ilja is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes it is, debian lenny
Reply With Quote
  #8  
Old 23rd November 2009, 19:40
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

I guess you installed debian updates too and not just a ispconfig update. Your problem is that the debian update installed a pure-ftpd version with capabilities enabled and this is incompatible with the vserver solution (openvz or virtuozzo) that is used on your server.

Please recompile pure-ftpd as you did initially as you installed the server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 24th November 2009, 14:50
AsDsL AsDsL is offline
Member
 
Join Date: Jul 2007
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi till,
I reinstalled as tutorial says again and now I have this problem:

Status: Connecting to 12.43.x.x:21...
Status: Connection established, waiting for welcome message...
Error: Connection timed out
Error: Could not connect to server
Status: Waiting to retry...

Thanks,
tony
Reply With Quote
  #10  
Old 25th November 2009, 13:42
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
 
Default

Please enable debugging in pure-ftpd and post the lines from the log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Mail not working epicuniversal General 5 13th June 2009 08:24
Details on problem /mailuser login and more (long) linutzy Installation/Configuration 11 15th February 2006 18:45
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 18:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.