#1  
Old 25th October 2009, 12:06
MadEgg MadEgg is offline
Junior Member
 
Join Date: Oct 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix smtp authentication

Hello!

I have ISPConfig 3 on a Ubuntu 8.04 LTS server and it all seems to work quite allright but now I run into a problem regarding postfix/smtp relay.

I would like to be able to use the server as an SMTP server that can relay mail to other mail servers. Of course I do not want an open relay so I would like to use authentication.

The problem is: when I specify no username and password, I get a message 'Relay not accepted' which seems fine, but when I do specify a username and password it does not accept it.

Is this functionality set up by default or do I need to change anything in the configuration? And what username/password should I use anyway? The client username/password for accessing the ISPConfig interface or a mailboxname, and if the latter, with or without the domain?

So, lets say my account in the ISPconfig interface is tvdwal, my email address is test@example.com, which should I use?
Reply With Quote
Sponsored Links
  #2  
Old 25th October 2009, 17:42
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

You use the email address and mailbox password, the same that you use for pop3 and imap. Just make sure that you enable smtp authentication in your email client and not SSL.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th October 2009, 02:16
MadEgg MadEgg is offline
Junior Member
 
Join Date: Oct 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No SSL? The 'Perfect Server Guide' is all over 'postfix with TLS' this and that, so why should I disable security?

Anyway, I tried disabling secure connections and enabled authentication using my IMAP username and password, still refuses... Any clues on what I should check?
Reply With Quote
  #4  
Old 26th October 2009, 03:10
MadEgg MadEgg is offline
Junior Member
 
Join Date: Oct 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Right, stupid. I checked /var/log/mail, and found these error messages:

warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
warning: 165-221.surfsnel.dsl.internl.net[145.99.221.165]: SASL LOGIN authentication failed: generic failure

The problem was that saslauthd was not started; the cause for this was that /etc/init.d/saslauthd script was not set executable. After I did this and added it to default runlevels, I could start saslauthd and now it works, including TLS. Thanks for the help!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 12:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.