Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th October 2009, 03:57
mkeigwin mkeigwin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default help postfix covecot opensuse 11.1

i have open suse postfix dovecot mail server set up
when i connect to the mail server from a vista pc , windows mail , i can only send email outgoing if i have the local server ip in the outgoing smtp address . if i try to use the mail server wan domain name i get a relay denied and can not send out email .

i will be moving this server to my work and i still need to be able to connect and send email from home .

where do i start to fix this , thanks
Reply With Quote
Sponsored Links
  #2  
Old 15th October 2009, 14:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Does the hostname point to your router's public IP, and is your router configured to forward port 25 to your mailserver?

It's also possible that your router doesn't suppport loopbacks. Or your provider is blocking port 25.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th October 2009, 15:32
mkeigwin mkeigwin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have a static ip and rev dns points back to my domain name . mx is set for mail.domain.com backup set for godaddy mail server .

this is a copy of my postfix main.cf

readme_directory = /usr/share/doc/packages/postfix-doc/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_alias_maps = hash:/etc/postfix/virtual
virtual_alias_domains = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = mikesrchobbies.com
myorigin = mikesrchobbies.com
delay_warning_time = 1h
message_strip_characters = \0
program_directory = /usr/lib/postfix
defer_transports =
disable_dns_lookups = no
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
append_dot_mydomain = no
swap_bangpath = no
masquerade_domains =
masquerade_execeptions = root
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
home_mailbox = Maildir/
relay_domains = mynetworks


this is a copy of my dovecot config file

## Dovecot configuration file


protocols = imap pop3 imaps pop3s

listen =

disable_plaintext_auth = no

ssl_listen =

ssl_disable = yes

mail_location = maildir:~/Maildir/

protocol imap {

mail_plugin_dir = /usr/lib64/dovecot/modules/imap

imap_client_workarounds = delay-newmail outlook-idle netscape-eoh
}

protocol pop3 {

pop3_uidl_format = %08Xu%08Xv
pop3_uidl_format = %v.%u

mail_plugin_dir = /usr/lib64/dovecot/modules/pop3

pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
}


protocol managesieve {

}
protocol lda {

postmaster_address = postmaster@example.com


mail_plugin_dir = /usr/lib64/dovecot/modules/lda


}

auth default {

mechanisms = plain

passdb passwd {
}

userdb passwd {
}



user = root
}
dict {
}
plugin {
}
login_process_size = 64

Last edited by mkeigwin; 15th October 2009 at 15:49.
Reply With Quote
  #4  
Old 16th October 2009, 14:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Does mail.domain.com point to your router's public IP?
Have you asked your ISP if they block port 25?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th October 2009, 06:42
mkeigwin mkeigwin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Does mail.domain.com point to your router's public IP?
Have you asked your ISP if they block port 25?
isp is not blocking port 25 and they set up the revers dns to point to my domain name . mx are correct and point back to my server . i added my public ip to the postfix main config , i setup windows mail to use the public ip as the mail server on both incoming and outgoing , seems to work from the same network , today i moves a windows 7 box to the office and it still does not want to send outgoing mail . but i can get incoming mail, still outgoing give the relay denied error , do i need to setup tls for this to work , as i do not want to use a web client , i would perfer to use imap.

server2:~ # dig mx mikesrchobbies.com

; <<>> DiG 9.5.0-P2 <<>> mx mikesrchobbies.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38883
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;mikesrchobbies.com. IN MX

;; ANSWER SECTION:
mikesrchobbies.com. 1800 IN MX 0 mikesrchobbies.com.
mikesrchobbies.com. 1800 IN MX 10 mailstore1.secureserver.net.

;; ADDITIONAL SECTION:
mailstore1.secureserver.net. 45 IN A 72.167.238.201

;; Query time: 58 msec
;; SERVER: 192.168.0.1#53(192.168.0.1)
;; WHEN: Sat Oct 17 00:18:49 2009
;; MSG SIZE rcvd: 111




server2:~ # nslookup 173.160.66.209
Server: 192.168.0.1
Address: 192.168.0.1#53

Non-authoritative answer:
209.66.160.173.in-addr.arpa name = mikesrchobbies.com.

Authoritative answers can be found from:

server2:~ # host 173.160.66.209
209.66.160.173.in-addr.arpa domain name pointer mikesrchobbies.com.
Reply With Quote
  #6  
Old 18th October 2009, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by mkeigwin View Post
still outgoing give the relay denied error
Can you post the exact error message?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 19th October 2009, 19:07
mkeigwin mkeigwin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Can you post the exact error message?
The message could not be sent. The authentication setting might not be correct for your outgoing e-mail [SMTP] server. For help solving this problem, go to Help, search for "Troubleshoot Windows Live Mail", and read the "I'm having problems sending e-mail" section. If you need help determining the proper server settings, please contact your e-mail service provider.

The rejected e-mail address was 'keigwinmichael@gmail.com'.

Subject 'test'
Server Error: 554
Server Response: 554 5.7.1 <keigwinmichael@gmail.com>: Relay access denied
Server: '173.160.66.209'
Windows Live Mail Error ID: 0x800CCC79
Protocol: SMTP
Port: 25
Secure(SSL): No
Reply With Quote
  #8  
Old 20th October 2009, 16:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you enable "Server requires authentication" in your email client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 20th October 2009, 18:21
mkeigwin mkeigwin is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no it is not turned on i have it set for clear for right now .
Reply With Quote
  #10  
Old 21st October 2009, 14:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by mkeigwin View Post
i have it set for clear for right now .
What do you mean with that?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 04:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.