Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th October 2009, 14:17
Manuel Manuel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default No Spam tags in headers of message

My mail server is set up so that spam mails are discarded, sent to a quarantine and then to the users´s maildirs without problems (except that in the process messages become not readable because there is no separation between headers and body! but that´s another story: see post http://www.howtoforge.com/forums/showthread.php?t=40373). As for their spammy condition they get correctly tagged by spamassassin in the headers and everything is fine.

So now I´m thinking about sending spam to the users inbox, so these are the settings in 20-debian_defaults:

#$QUARANTINEDIR = "$MYHOME/virusmails"; # spam quarantine, not for virus
$sa_spam_subject_tag = '***SPAM*** ';

$final_spam_destiny = D_PASS;
#$final_spam_destiny = D_DISCARD;

The log is like that (it looks fine):

Oct 27 11:55:49 correo amavis[19570]: (19570-04) Passed SPAM, [213.4.129.24] [88.25.147.89] <wenmate@nexsus.com> -> <henrich3@domain.com>, Message-ID: <20091027105542.544A8CF01D7@domain.com>, mail_id: 0h6TxrVntCmK, Hits: 8.889, 6440 ms
Oct 27 11:56:06 correo amavis[19430]: (19430-09) Passed SPAM, [109.165.180.22] [109.165.180.22] <834859794.03591330329094@complex.es> -> <834859794.03591330329094@domain.com>, Message-ID: <20091027105544.3E119CF019C@domain.com>, mail_id: WXjelE-+xN63, Hits: 17.76, 8265 ms

The spam mail gets OK (they are readable) in the user´s inbox but they don´t get tagged in the headers nor in the subject so it will be certainly difficult for the users to know about what is spam and what is not. Any ideas?

Manuel

Last edited by Manuel; 9th November 2009 at 20:23.
Reply With Quote
Sponsored Links
  #2  
Old 28th October 2009, 15:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

How exactly did you set up your server? Did you use a tutorial from here? If so, what URL?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th October 2009, 18:56
Manuel Manuel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Yes, Falko, I used your "Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch)" at http://www.howtoforge.com/virtual_us...ix_debian_etch

Thanks
Manuel
Reply With Quote
  #4  
Old 29th October 2009, 22:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What spam scores are you using in your amavisd configuration?

Is this a Debian Etch server, or is it Lenny?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th October 2009, 22:48
Manuel Manuel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Finally I got it right! I was wrong about a few things in the settings I had in 20-debian_defaults:

#$QUARANTINEDIR = "$MYHOME/virusmails"; # spam quarantine, not for virus
$sa_spam_subject_tag = '***SPAM*** ';
$final_spam_destiny = D_PASS;
#$final_spam_destiny = D_DISCARD;

and this is right
$QUARANTINEDIR = "$MYHOME/virusmails"; # spam quarantine, not for virus
$sa_spam_subject_tag = '***SPAM*** ';
#$final_spam_destiny = D_PASS;
$final_spam_destiny = D_DISCARD;

I just came across a unique guide which explains amavis-new settings and followed it to the letter. It's url http://www200.pair.com/mecham/spam/a...-settings.html
You have to set $sa_tag_level_deflt to undef or -9999 and the most important $sa_kill_level_deflt = is the score where mails are thrown into the quarantine.
$sa_tag2_level_deflt = is the score where the subject is rewritten. In between these two levels the mails pass to the users with their subject rewritten.
You have to get local_domains_maps right or things won't work.

Thanks everybody

Manuel
Reply With Quote
The Following User Says Thank You to Manuel For This Useful Post:
falko (30th October 2009)
  #6  
Old 29th October 2009, 22:57
Manuel Manuel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default

Hi Falko! our posts crossed! I just posted my solution (in Etch) a moment ago. I'm still not sure about $sa_kill_level_deflt . I've set it to 12.

Thanks for your interest

Manuel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
Dspam + postfix : dspam didn't tag header messages NothingHere Server Operation 1 31st October 2008 16:57
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37
No Spam Headers after upgrading to Etch snowfly Server Operation 2 11th October 2007 00:13
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59


All times are GMT +2. The time now is 01:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.