#1  
Old 30th April 2006, 13:31
symmetry symmetry is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default sftp problem

Hello

my ssh login over putty works without any problems but when I try to connect via my ftp software I get the follwoing error:

Quote:
ERROR:> No further authentication methods available.
ERROR:> The requested operation failed for an unknown reason.
ERROR:> Can't connect to xxxxxx:22. SFTP21 error = #4.
I use cute ftp
Reply With Quote
Sponsored Links
  #2  
Old 30th April 2006, 14:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Have a look here: http://www.openssh.com/faq.html#2.9
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 30th April 2006, 22:17
symmetry symmetry is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, I made the ssh yourhost /usr/bin/true but I don't know what to do next

Quote:
The authenticity of host 'yourhost.net (xxx.xx.xx.9)' can't be established.
RSA key fingerprint is 65:44:92:00:97:0f:5b:ce:63:5f:79:2e:c3:51:52:9c.
Are you sure you want to continue connecting (yes/no)?
iIf I choose yes, he asks me a password, but none of my system passwords match
Reply With Quote
  #4  
Old 30th April 2006, 22:20
symmetry symmetry is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hmm

it could be that cuteftp has some probs, because I can access the server with the sftp command from another root server


sftp asks me to acceppt a key, and than it works.

cute ftp does the same, but it doesn't work for him...
Reply With Quote
  #5  
Old 1st May 2006, 11:55
symmetry symmetry is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

with winscp I am able to connect to my server
Reply With Quote
  #6  
Old 1st May 2006, 15:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

This seems to be a CuteFTP problem then...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 1st May 2006, 19:51
symmetry symmetry is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

but I use Cuteftp for some other servers where he has no problems, and I also cannot connect with WS_FTP.
Reply With Quote
  #8  
Old 2nd May 2006, 15:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
Default

Do you also use SFTP on your other servers, or only FTP?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 2nd May 2006, 16:32
symmetry symmetry is offline
Junior Member
 
Join Date: Apr 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use SFTP on those servers
Reply With Quote
  #10  
Old 3rd May 2006, 15:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,730 Times in 2,568 Posts
 
Default

Have you compared your SSH configuration on your servers?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Unable to connect (iptables problem?) Samatttv Installation/Configuration 3 27th April 2006 22:03
sftp acess for Web users anuragj Installation/Configuration 2 6th February 2006 23:41
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56


All times are GMT +2. The time now is 13:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.