#1  
Old 19th October 2009, 16:35
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default phpmyadmin 403

After the update (not 100% sure if this causes it) to 3.0.16 mydomain.com/phpmyadmin is not available anymore. It gives a 403 error message.

Edit: Just checked my 2 new servers that I updated this morning to the latest stable version of ispconfig and also here phpmyadmin is not available because of a 403 error.

Last edited by skoena; 19th October 2009 at 16:38.
Reply With Quote
Sponsored Links
  #2  
Old 19th October 2009, 22:14
Tomsworld Tomsworld is offline
Junior Member
 
Join Date: Apr 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same issue here.

Code:
client denied by server configuration: /usr/share/phpmyadmin/
It seems to be related to my .4 -> .6 upgrade.

Last edited by Tomsworld; 19th October 2009 at 22:18.
Reply With Quote
  #3  
Old 19th October 2009, 22:34
insideoutsolutions insideoutsolutions is offline
Junior Member
 
Join Date: Jan 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=40193

Same issue on two servers.
Reply With Quote
  #4  
Old 19th October 2009, 23:53
Tomsworld Tomsworld is offline
Junior Member
 
Join Date: Apr 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just found following bug id:

http://bugtracker.ispconfig.org/inde...ls&task_id=937
Reply With Quote
  #5  
Old 20th October 2009, 00:02
insideoutsolutions insideoutsolutions is offline
Junior Member
 
Join Date: Jan 2009
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the link. I'm looking through the security ramifications of the workaround.
Reply With Quote
  #6  
Old 20th October 2009, 11:10
skoena skoena is offline
Senior Member
 
Join Date: Sep 2009
Location: Emmen, Netherlands
Posts: 421
Thanks: 77
Thanked 14 Times in 12 Posts
Send a message via MSN to skoena Send a message via Skype™ to skoena
Default

I used the workaround and my phpmyadmin is available again.
Till, is this a secure way to do it? Or is it better to install phpmyadmin as a separate website like you mentioned?

Quote:
Comment by Till (Till) - Saturday, 17 October 2009, 12:28 GMT+2
Here a workaround for debian to use phpmyadmin and squirrelmail.

Edit the file:

/etc/apache2/sites-enabled/000-ispconfig.conf

and add the following lines at the end:

<Directory /usr/share/phpmyadmin>
Order allow,deny
Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
Order allow,deny
Allow from all
</Directory>
Reply With Quote
  #7  
Old 20th October 2009, 11:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,983
Thanks: 825
Thanked 5,372 Times in 4,219 Posts
 
Default

This workaround is secure.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
rudolfpietersma (20th October 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot login to phpmyadmin atjensen11 HOWTO-Related Questions 3 31st August 2009 18:07
httpd and phpmyadmin recirect issue moglia Developers' Forum 5 11th August 2009 12:52
phpMyAdmin goes PHP5 & MySQL5 Hans General 5 28th September 2008 20:46
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57


All times are GMT +2. The time now is 21:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.