Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th November 2010, 01:04
pootle pootle is offline
Junior Member
 
Join Date: Feb 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default [web server] domain with alias to system application does not render php.

I have a domain which references an application on the system that serves out php pages.

it resides under /usr/share/webapp . Php works perfectly fine under my users accounts and any php under the web directory of the client works fine. However when the alias is invoked the php page downloads as if nothing was configured :/

I've tried adding :

<IfModule mod_suphp.c>
suPHP_Engine on
# suPHP_UserGroup web2 client1
AddHandler x-httpd-suphp .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-suphp
</IfModule>

to the alias directory but I still get the same result... If I configure the site outside of ISPConfig control it'll work perfectly fine but I didn't want to do this as this app can be used by more than one user and it'll defeat the object of using ISPConfig.

I know I've missed something obvious but can anyone help here?
Reply With Quote
Sponsored Links
  #2  
Old 10th November 2010, 01:22
pootle pootle is offline
Junior Member
 
Join Date: Feb 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

ignore this i worked it out!

tiredness is not my friend and it's been a while since I last looked at a webserver config


the solution is not to use suphp for this alias but to use modphp instead. My chrome seemed to cache the page longer ( even on full refresh ) than firefox and when I ran it in firefox I got a script error which indicated the ownership for the script was wrong. Seeing as multiple users can reference this app the solution is not to use suphp and use modphp or something else instead.

works now


<Directory /usr/share/webapp/>

DirectoryIndex index.php
Options -Indexes +FollowSymLinks
AllowOverride Options
Order allow,deny
AddType application/x-httpd-php .php .php3 .php4 .php5
</Directory>

*facepalm*
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
ISPConfig virtual web pages not working mike_phi Installation/Configuration 8 7th May 2008 16:51
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 13th March 2006 23:58


All times are GMT +2. The time now is 16:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.