Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th October 2009, 19:09
SrTango SrTango is offline
Junior Member
 
Join Date: Oct 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default multiple server update server.php script

Hi,
I don't quite get the following
on server.php script that one that runs every minute you can see something like:
$server_db_record = $app->db->queryOneRecord("SELECT * FROM server WHERE update = 1 AND server_id = ".$conf["server_id"]);

but there is no update field on that table the field is actually called updated (probably to avoid using a reserved word in mysql and having to quote or add server.update) anyway I just dont get if I am missing something or this is actually a bug

mysql> describe server;
+----------------+---------------------+------+-----+---------+----------------+
| Field | Type | Null | Key | Default | Extra |
+----------------+---------------------+------+-----+---------+----------------+
| server_id | int(11) unsigned | NO | PRI | NULL | auto_increment |
| sys_userid | int(11) unsigned | NO | | 0 | |
| sys_groupid | int(11) unsigned | NO | | 0 | |
| sys_perm_user | varchar(5) | NO | | | |
| sys_perm_group | varchar(5) | NO | | | |
| sys_perm_other | varchar(5) | NO | | | |
| server_name | varchar(255) | NO | | | |
| mail_server | tinyint(1) | NO | | 0 | |
| web_server | tinyint(1) | NO | | 0 | |
| dns_server | tinyint(1) | NO | | 0 | |
| file_server | tinyint(1) | NO | | 0 | |
| db_server | tinyint(1) | NO | | 0 | |
| vserver_server | tinyint(1) | NO | | 0 | |
| config | text | NO | | NULL | |
| updated | bigint(20) unsigned | NO | | 0 | |
| active | tinyint(1) | NO | | 1 | |
+----------------+---------------------+------+-----+---------+----------------+


so should I change the script or I am really missing someting?

Thanks,
Reply With Quote
Sponsored Links
  #2  
Old 16th October 2009, 09:40
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Looks as if your servers are not up to date. This has been changed in ispconfig some time ago. Please update all your servers to ispconfig 3.0.1.6 which will be released today. Dont use 3.0.1.5 as it contians a bug in the updater for multiserver setups.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th October 2009, 21:59
SrTango SrTango is offline
Junior Member
 
Join Date: Oct 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Looks as if your servers are not up to date. This has been changed in ispconfig some time ago. Please update all your servers to ispconfig 3.0.1.6 which will be released today. Dont use 3.0.1.5 as it contians a bug in the updater for multiserver setups.
AHHHHH I knew it.
I've been fighting the whole day with update issues. The call center hates me, the clients hates them. I had to dump (thank god for '--where' mysqldump parameter) to update some servers.

In the other hand 3.0.1.5 has some issues with failed updates that ends up clearing your whole database, again, thank god for daily dumps.

Anyway thank you for your answer I was about to go crazy
Reply With Quote
  #4  
Old 16th October 2009, 23:31
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,483
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Quote:
In the other hand 3.0.1.5 has some issues with failed updates that ends up clearing your whole database, again, thank god for daily dumps.
Thats why we released 3.0.1.6. But the problem occurs only on slaves of multiservers systems and not masters, so you can simply copy the database from the master to the slave, no need to use any backups.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th October 2009, 04:23
SrTango SrTango is offline
Junior Member
 
Join Date: Oct 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
Thats why we released 3.0.1.6. But the problem occurs only on slaves of multiservers systems and not masters, so you can simply copy the database from the master to the slave, no need to use any backups.
Yeah but that will copy the full database which AFAIK is not the idea. (not sure tho, I'm been messing with ispconfig for a few weeks only)
so when it first happened to me I took the conservative approach of copying the mail_user server mail_forwarding (And a few others that I cant remember) but only where server_id = the server_id of the server I was trying to reconstruct.
After that I just started making a daily dump and a pre update dump (which I believe is now part of the standard update or I just missed that it was already part of it)

Anyway it just works now which is always a good thing
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 17:54
Creating one "per-user" login script on Ubuntu server awe HOWTO-Related Questions 3 8th May 2009 02:24
Can't start apache Musty Server Operation 12 9th March 2008 14:58
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 06:19


All times are GMT +2. The time now is 15:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.