#1  
Old 21st December 2009, 18:23
shaker shaker is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sites Directory

Hi everyone
How do i install ISPConfig 3 and make sites working on /home/admin/public_html instead of /var/clients?
Any help is welcome, Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2009, 09:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

You will have to rewrite the apache plugin if you want to do that. But be aware that you will not be able to update your system afterwards or you add all patches to your codebase in future manually.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd December 2009, 10:09
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Wouldn't it be possible to just mount the /var/clients to the desired directory?
Reply With Quote
  #4  
Old 22nd December 2009, 10:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

But then still the client directories will be in /home/admin/public_html and not the sites as ispconfigs folder hierarchy is [client]/[site]/web. So what he can do is to have /home/admin/public_html/[client]/[site]/web but not /home/admin/public_html/[site]/web by mounting the directory. Also he should be aware that things like suexec will not work if the sites are not in /var/www as its the default in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd December 2009, 11:04
shaker shaker is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thank you very much.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 13:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.