Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th October 2009, 17:00
neverdie neverdie is offline
Junior Member
 
Join Date: Oct 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default mod_qos install problem-- New bie, Help me pls

Hi

My Server use CentOS and I have installed mod_qos like this.

#cd mod_qos-8.18/apache2/

#apxs -i -c mod_qos.c

Then it show statement below ,so it seem libraries installed already .

--------------------------------------------
Libraries have been installed in:
/usr/lib/apache
If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'
See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so( manual pages.

--------

#chmod 755 /usr/lib/apache/mod_qos.so

#cd etc/httpd/conf

#nano qos.conf


My qos.conf

## QoS Settings
<IfModule mod_qos.c>
QS_ClientEntries 100000

QS_SrvMaxConnPerIP 20

MaxClients 256

QS_SrvMaxConnClose 180

QS_SrvMinDataRate 150 1200

</IfModule>


I add statement below to my httpd.conf

> LoadModule qos_module /usr/lib/apache/mod_qos.so

and include qos.conf

> Include “/etc/httpd/conf/qos.conf”

Now i restart apache

service httpd restart

but when i restart apache I 'm not able to get the server-status by http://serverip/server-status

It show error


Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache Server at xxx.xxx.xxx.xxx Port 80
www.aaaa.com:80 (virtual)
uses base server settings

www.ccccc.com:80 (virtual)
uses base server settings

www.bbbb.com:80 (virtual)
uses base server settings

www.ddddd.com:80 (virtual)
uses base server settings

--------------------------------------------

In apache error log show

>mod_qos(045): access denied, invalid request line: can't parse uri


Normally I can use server-status<mod_status> to show detail about request to apache but when I load module modqos in my httpd.conf it has internal server error. I think it has problem in qos.conf but when coment

# Include “/etc/httpd/conf/qos.conf”

It remain internal server error.

Some one can help me pls.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Portsentry install problem Kev King Installation/Configuration 11 7th September 2010 12:23
Setup problem ? affecting Joomla 1.5 install luoto Installation/Configuration 9 11th January 2008 09:38
Problem with spanassassin on install Desorder Installation/Configuration 1 29th December 2007 14:00
Fedora Core 4 and hp Printer install problem. slopoke_iii Desktop Operation 3 5th May 2007 22:27
MySQL problem on install badben Installation/Configuration 12 20th December 2005 12:59


All times are GMT +2. The time now is 13:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.