Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st March 2011, 17:36
poisonborz poisonborz is offline
Junior Member
 
Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Changing basedir outside the web interface

Hola,
I'm new to ispconfig - I tried to change the basedir, but of course messed it up, and now I can't log in to the web interface.
Where can I find a config file where I can set back /var/www ?
Thanks
Reply With Quote
Sponsored Links
  #2  
Old 2nd March 2011, 08:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,473
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

You can not set the open_basedir in ispconfig for the ispconfig web interface. So you must have changed something else which caused the login problem.

Which exact error message do you get?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd March 2011, 11:38
poisonborz poisonborz is offline
Junior Member
 
Join Date: Mar 2011
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

What I did was System > Server Config > and after selecting server, on the Web tab, I changed website basedir, path and symlinks (in each line I replaced /var/www with a different path). Naturally after this change the web interface was not loaded with "unable to connect".

Not much later I realized this was completely unnecessary as I can achieve my goal much easier by loading /var/www with "mount --bind" in the desired directory (the one I changed the path to earlier). But after doing this, the "unable to connect" message remained. The I've also tried to copy the contents (with working symlink in the case of the ispconfig folder) but had still no success.

I solved the problem by reinstalling ispconfig, but the question still remains: after a failed basedir/path/symlink change, is there a way to reset this setting in the database or in a config file?
Reply With Quote
  #4  
Old 2nd March 2011, 11:57
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,473
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
 
Default

Quote:
I solved the problem by reinstalling ispconfig, but the question still remains: after a failed basedir/path/symlink change, is there a way to reset this setting in the database or in a config file?
You will have to look into the ispconfig vhost file in /etc/apache2/sites-enabled/ and correct the paths. It might also be nescessary to correct symlinks in /var/www and in the clinets directories and you will have to replace the path in the server table in the ispconfig database.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm attack brute force qb7 General 6 21st July 2012 21:34
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Changing priority of DNS A record in web interface fed Feature Requests 1 17th July 2009 10:43
chgrp error new user DKA General 15 28th July 2008 17:45
get thousands of "Mailsize" mails from own server torusturtle Installation/Configuration 20 24th December 2006 14:51


All times are GMT +2. The time now is 16:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.