Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th October 2009, 13:36
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 83
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to Stown
Default SMTP connection failt

Hi,

My smtp server dont't send mail correctly.
I get mail back and it says:

Recipient address rejected: User unknown in virtual mailbox table (in reply to RCPT TO command)

I got the mail back when i followed this page: http://pingability.com/smtptest.jsp it should send the mail succesfully to a mail adres from pingability.com

Someone who knows the solution?

Thank you

Last edited by Stown; 8th October 2009 at 13:38.
Reply With Quote
Sponsored Links
  #2  
Old 9th October 2009, 12:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,379 Times in 4,226 Posts
Default

Please test your server with a locally installed webmail client instead by sending a email from a local account on the server to itself and take a look at the mail log file if you get any errors.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th October 2009, 15:27
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 83
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to Stown
Default

In the webmail sending emails went good but when i do external smtp via Outlook or something else it goes wrong, i get the error when sending mail that says "The smtp server dont accept this smtp connection"

Last edited by Stown; 11th October 2009 at 21:05.
Reply With Quote
  #4  
Old 12th October 2009, 11:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,379 Times in 4,226 Posts
Default

Please post the exact error message from the mail log that appears when the smtp connection is rejected.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th October 2009, 18:56
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 83
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to Stown
Default

In the logs i cannot find anything whats helpfull. This is the tail of maillog
Oct 12 18:49:07 server1 amavis[30653]: (30653-03) post_process_request_hook: timer was not running
Oct 12 18:49:07 server1 amavis[30653]: (30653-03) idle_proc, bye: was busy, 1.9 ms, total idle 2111.043 s, busy 8.024 s
Oct 12 18:49:07 server1 amavis[30653]: (30653-03) load: 0 %, total idle 2111.043 s, busy 8.024 s
Oct 12 18:50:01 server1 postfix/smtpd[695]: connect from server1.s-projects.nl[127.0.0.1]
Oct 12 18:50:01 server1 postfix/smtpd[695]: lost connection after CONNECT from server1.s-projects.nl[127.0.0.1]
Oct 12 18:50:01 server1 postfix/smtpd[695]: disconnect from server1.s-projects.nl[127.0.0.1]
Oct 12 18:50:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
Oct 12 18:50:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Oct 12 18:50:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Oct 12 18:50:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0


When i do in windows 7 in CMD.exe [ telnet 213.163.64.99 25] i get connecting.... .... connection failed
Reply With Quote
  #6  
Old 13th October 2009, 15:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are you sure that you're connecting to the correct server in Outlook? Have you tried the server's IP instead of a hostname in Outlook?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 13th October 2009, 17:00
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 83
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to Stown
Default

Yes because when i do the telnet option it doesnt work, but when i do telnet on imap port 143 then it goes goed
Reply With Quote
  #8  
Old 14th October 2009, 14:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
netstat -tap
?
Is the server hosted in a data center, or do you host it at home or in your office?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th October 2009, 18:43
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 83
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to Stown
Default

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:sanity *:* LISTEN 2157/rpc.statd
tcp 0 0 server1.s-projects.nl:10024 *:* LISTEN 27749/amavisd (ch5-
tcp 0 0 server1.s-projects.nl:10025 *:* LISTEN 30561/master
tcp 0 0 *:mysql *:* LISTEN 30488/mysqld
tcp 0 0 server1.s-proje:dyna-access *:* LISTEN 30654/clamd
tcp 0 0 *:sunrpc *:* LISTEN 2116/portmap
tcp 0 0 213.163.64.101:domain *:* LISTEN 30783/mydns
tcp 0 0 213.163.64.100:domain *:* LISTEN 30783/mydns
tcp 0 0 213.163.64.99:domain *:* LISTEN 30783/mydns
tcp 0 0 server1.s-projects.n:domain *:* LISTEN 30783/mydns
tcp 0 0 *:ftp *:* LISTEN 30758/pure-ftpd (SE
tcp 0 0 *:smtp *:* LISTEN 30561/master
tcp 0 0 server1.s-projects.nl:49211 server1.s-projects.nl:mysql ESTABLISHED 27749/amavisd (ch5-
tcp 0 0 server1.s-projects.nl:mysql server1.s-projects.nl:49211 ESTABLISHED 30488/mysqld
tcp 0 0 server1.s-projects.nl:32931 server1.s-projects.nl:mysql ESTABLISHED 28200/amavisd (ch4-
tcp 0 0 server1.s-projects.nl:mysql server1.s-projects.nl:32931 ESTABLISHED 30488/mysqld
tcp 0 0 *:imaps *:* LISTEN 30708/couriertcpd
tcp 0 0 *op3s *:* LISTEN 30720/couriertcpd
tcp 0 0 *op3 *:* LISTEN 30714/couriertcpd
tcp 0 0 *:imap *:* LISTEN 30701/couriertcpd
tcp 0 0 *:webcache *:* LISTEN 30734/httpd
tcp 0 0 *:http *:* LISTEN 30734/httpd
tcp 0 0 localhost6.localdoma:domain *:* LISTEN 30783/mydns
tcp 0 0 *:ftp *:* LISTEN 30758/pure-ftpd (SE
tcp 0 0 *:ssh *:* LISTEN 2384/sshd
tcp 0 2072 ::ffff:213.163.64.99:ssh ip5653eaed.direct-ads:49289 ESTABLISHED 1894/0
Reply With Quote
  #10  
Old 15th October 2009, 10:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,011
Thanks: 826
Thanked 5,379 Times in 4,226 Posts
 
Default

The mailserver is listening on port 25, so that ok. Please post the output of:

iptables -L

also make sure that your internet access provider does not block port 25.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
Attacks on MTA dclardy Installation/Configuration 4 29th September 2009 16:50
Mail not working epicuniversal General 5 13th June 2009 08:24
debian etch courier pop3 issue docean Installation/Configuration 6 20th March 2008 15:38
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 16:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.