Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd October 2009, 15:06
thabangk thabangk is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364

Hi

I can't get to restart the postfix.i get this error and all my packages i installed them using yum what may be wrong?I'm using centos 4.7

Starting Mail Virus Scanner (amavisd): DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364.
[FAILED]

This is the error i got in the maillog:

Oct 2 14:03:02 server1 amavis[6441]: starting. /usr/sbin/amavisd at server1.example.com amavisd-new-2.6.4 (20090625), Unicode aware, LANG="en_US.UTF-8"
Oct 2 14:03:02 server1 amavis[6441]: Perl version 5.008005

and in the messages log i got this:

unuser: DBI version 1.43 required--this is only version 1.40 at /usr/sbin/amavisd line 13364

Please help!!!!!!!!!!!
Reply With Quote
Sponsored Links
  #2  
Old 3rd October 2009, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

You must install the newest DBI Perl module. We do this on the Perl shell:

Code:
perl -MCPAN -e shell
Once you are on the Perl shell, you can install DBI as follows:

Code:
install DBI
Type

Code:
q
afterwards to leave the Perl shell.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th October 2009, 10:53
thabangk thabangk is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi

Just got this when running install DBI

*** Your LANG environment variable is set to 'en_US.UTF-8'
*** This may cause problems for some perl installations.
*** If you get test failures, please try again with LANG unset.
*** If that then works, please email dbi-dev@perl.org with details
*** including the output of 'perl -V'

and at the end got this:

Writing Makefile for DBI
make: *** No rule to make target `[]'. Stop.
/usr/bin/make [] -- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

And again in the maillog i got this after trying to restart the amavisd service:
Oct 5 10:21:25 server1 amavis[6933]: starting. /usr/sbin/amavisd at server1.example.com amavisd-new-2.6.4 (20090625), Unicode aware, LANG="en_US.UTF-8"
Oct 5 10:21:25 server1 amavis[6933]: Perl version 5.008005



What does it mean??

Last edited by thabangk; 5th October 2009 at 11:29.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 21:17
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 17:27
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 14:06
help on /etc/rc0.d/K20dnsctl -> ../init.d/dnsctl zimele General 13 23rd August 2006 17:06


All times are GMT +2. The time now is 00:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.