Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th September 2009, 23:37
NDIS NDIS is offline
Junior Member
 
Join Date: Aug 2009
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation At some point in the web dir all permissions denied

hello there,

Ive uploaded a photoalbum wich uses PHP.

I always get this error becouse the script has no permissions.

Code:
Warning: chmod() [function.chmod]: Operation not permitted in /var/www/clients/client1/web2/web/album/include/functions.php on line 1022

An error occured whilst creating thumbnail for image /lloretdemar/DSCF0003.JPG

Unable to rename [/var/www/clients/client1/web2/tmp/dalbum_5b271384333084d6abca859b30fe1334.JPG] to [./pictures/lloretdemar/_res/res_DSCF0003.JPG].
And i realy dont know how to fix this.
I think the user or something does not have access.

Can someone help me out?
Reply With Quote
Sponsored Links
  #2  
Old 29th September 2009, 09:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

If a CMS system shall be able to the website, you have to set PHP either to suphp or use php-fcgi + suexec or php-cgi+suexec.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th September 2009, 22:45
NDIS NDIS is offline
Junior Member
 
Join Date: Aug 2009
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your response.

I have tryed all the options. Always the same. And if suexec is on i get internal server error 500.

Its a photoalbum wich is generating thumbnails. It just dont have the permission rights.


If i am on FTP in this folder: /var/www/clients/client1/web2/web/album

i cant make folders, so with FTP i also dont have permission to do things there.


Is it posseble to fix this?

Last edited by NDIS; 29th September 2009 at 23:01.
Reply With Quote
  #4  
Old 30th September 2009, 09:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Please enable php-fcgi with suexec. Then take am look at the error log of the website to get the detailed reason for the 500 error. Most likely you uploaded the PHP files with wrong permissions.

Quote:
i cant make folders, so with FTP i also dont have permission to do things there.
Then you added the files with wrong permissions. Make sure that the files belong to the user web2 and the group client1.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 30th September 2009, 19:11
NDIS NDIS is offline
Junior Member
 
Join Date: Aug 2009
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

How can i upload the files with the right permissions? I just uploaded the script to the folder album.

I've now used FCGI PHP with SuEXEC.
And still get this error:
Quote:
Warning: chmod() [function.chmod]: Operation not permitted in /var/www/clients/client1/web2/web/album/include/functions.php on line 1022

An error occured whilst creating thumbnail for image /lloretdemar/DSCF0003.JPG

Unable to rename [/var/www/clients/client1/web2/tmp/dalbum_5b271384333084d6abca859b30fe1334.JPG] to [./pictures/lloretdemar/_res/res_DSCF0003.JPG].
What to do! hehe,
Thanks that you are helping me!
Reply With Quote
  #6  
Old 1st October 2009, 10:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Looks as if you have added chmod to the disabled functions list in the php.ini file. You have to remove it from there when you want to use chmod in your scripts.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 1st October 2009, 17:57
NDIS NDIS is offline
Junior Member
 
Join Date: Aug 2009
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Then you added the files with wrong permissions. Make sure that the files belong to the user web2 and the group client1.
How can i do this?


i've looked in serveral php.ini files but there is no chmod in the files. so i quess its already out.

Wich php.ini file do i need?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Default Web Dir fro Installation/Configuration 1 21st October 2006 12:03
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 02:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.