#1  
Old 30th September 2009, 22:55
tuananh87vn tuananh87vn is offline
Member
 
Join Date: Sep 2009
Posts: 39
Thanks: 8
Thanked 0 Times in 0 Posts
Default enable smpts (port 465)

Hi,
I'm following the howto of installing postfix on debian and have nearly reached the end. At the moment, i can receive email using pop3/pop3s/imap/imaps and send mail using only smpt. I run a nmap and notice that port 110, 995, 143, 993 and 25 were open, but there's no open port 465 needed for smpts.

How was that, is port 465 intended to open in the howto? or how to open that port so that i can send email securely using smpts.

thanks alot!
Reply With Quote
Sponsored Links
  #2  
Old 30th September 2009, 23:02
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default

This post might help.
http://www.howtoforge.com/forums/showthread.php?t=7057
Reply With Quote
The Following User Says Thank You to edge For This Useful Post:
tuananh87vn (1st October 2009)
  #3  
Old 1st October 2009, 06:21
tuananh87vn tuananh87vn is offline
Member
 
Join Date: Sep 2009
Posts: 39
Thanks: 8
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by edge View Post
ah yes, that's great. Thanks so much!

My mistake is that just uncommented the first line only:
Code:
#smtps    inet  n       -       -       -       -       smtpd
this makes postfix listen on port 465 yet that's not enough, i couldn't configure my email client to send email thru port 465 (encryption type is ssl)

only when the next line is removed comment
Code:
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
i can send message wrapped by ssl

by the way, if i just uncommend the first line, i could still send message under port 25 with tls. So what's the difference btw ssl and tls, can u explain it for me?

thank you edge, and you, falko, for your outstanding howto!

Last edited by tuananh87vn; 1st October 2009 at 06:28.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 18:57
Installation -- pcre_exec.c:403: internal compiler error: Segmentation fault zerman Installation/Configuration 2 24th September 2008 00:58
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 14:15
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 17:33
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40


All times are GMT +2. The time now is 06:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.