Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th September 2009, 00:24
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default remote email user cannot send email to local domain

I have a remote office worker that needs to be able to send email to to local domain and outside users. currently when we try to email we get the following.

Task 'mike@(deleted-domain).com - Sending' reported error (0x80042109) : 'Outlook cannot connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).'

I am using the domain address for the incoming and outgoing mail server. useing the web_mike as the username.

I did a netstat -tap and get this

(No info could be read for "-p": geteuid()=1000 but you should be root.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN -
tcp 0 0 *:www *:* LISTEN -
tcp 0 0 *:81 *:* LISTEN -
tcp 0 0 192.168.254.174:domain *:* LISTEN -
tcp 0 0 localhost:domain *:* LISTEN -
tcp 0 0 *:ssh *:* LISTEN -
tcp 0 0 *:smtp *:* LISTEN -
tcp 0 0 localhost:953 *:* LISTEN -
tcp 0 0 *:https *:* LISTEN -
tcp 0 416 192.168.254.174:ssh 99-39-166-185.lig:51187 ESTABLISHED -
tcp6 0 0 [::]:imaps [::]:* LISTEN -
tcp6 0 0 [::]op3s [::]:* LISTEN -
tcp6 0 0 [::]op3 [::]:* LISTEN -
tcp6 0 0 [::]:imap2 [::]:* LISTEN -
tcp6 0 0 [::]:ftp [::]:* LISTEN -
tcp6 0 0 [::]:ssh [::]:* LISTEN -
tcp6 0 0 [::]:smtp [::]:* LISTEN -
tcp6 0 0 localhost:953 [::]:* LISTEN -

am I right assuming that port 25 is not open to the outside?

Last edited by mtutaj; 26th September 2009 at 00:42.
Reply With Quote
Sponsored Links
  #2  
Old 26th September 2009, 14:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is there a firewall on the server? What's the output of
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th September 2009, 23:37
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

this is after running iptables -L
Reply With Quote
  #4  
Old 27th September 2009, 12:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

No firewall, so that's not the problem. Have you tried to restart Postfix? Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 5th October 2009, 05:36
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,

I see my Ip address in the logs, but dont see any errors. I tried posting to pastebin, but it trips their spam filter.

Having the same issue with pop3 and imap. This is getting frustrating.. I need to move over 8 more domains, but I can't till this is straightened out.

Let me know what else I should try..

Thanks,

Mike
Reply With Quote
  #6  
Old 5th October 2009, 13:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You can post an excerpt of your mail log here - no need to use pastebin.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 5th October 2009, 16:36
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Oct 4 11:52:56 webserver1 postfix/qmgr[30477]: D5E5220056B: removed
Oct 4 11:54:06 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:54:06 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:54:06 webserver1 pop3d: LOGIN, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49607]
Oct 4 11:54:06 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49610], protocol=IMAP
Oct 4 11:54:06 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:54:06 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49612], protocol=IMAP
Oct 4 11:54:07 webserver1 pop3d: LOGOUT, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49607], top=0, retr=0, rcvd=24, sent=1550, time=1
Oct 4 11:54:07 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:54:07 webserver1 pop3d: LOGIN, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49613]
Oct 4 11:54:08 webserver1 pop3d: LOGOUT, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49613], top=0, retr=0, rcvd=24, sent=133, time=1
Oct 4 11:54:45 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=96, sent=500, time=39
Oct 4 11:54:45 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=65, sent=202, time=39
Oct 4 11:56:03 webserver1 postfix/anvil[15427]: statistics: max connection rate 1/60s for (smtp:89.75.187.80) at Oct 4 11:52:37
Oct 4 11:56:03 webserver1 postfix/anvil[15427]: statistics: max connection count 1 for (smtp:89.75.187.80) at Oct 4 11:52:37
Oct 4 11:56:03 webserver1 postfix/anvil[15427]: statistics: max cache size 1 at Oct 4 11:52:37
Oct 4 11:59:16 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:59:16 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:59:16 webserver1 pop3d: LOGIN, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49621]
Oct 4 11:59:16 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49624], protocol=IMAP
Oct 4 11:59:16 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:59:16 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49626], protocol=IMAP
Oct 4 11:59:16 webserver1 pop3d: LOGOUT, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49621], top=0, retr=0, rcvd=24, sent=1550, time=0
Oct 4 11:59:17 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 11:59:17 webserver1 pop3d: LOGIN, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49627]
Oct 4 11:59:17 webserver1 pop3d: LOGOUT, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49627], top=0, retr=0, rcvd=24, sent=133, time=0
Oct 4 11:59:55 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=96, sent=500, time=39
Oct 4 11:59:55 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=65, sent=202, time=39
Oct 4 12:04:16 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:04:16 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:04:16 webserver1 pop3d: LOGIN, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49652]
Oct 4 12:04:16 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49655], protocol=IMAP
Oct 4 12:04:16 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:04:16 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49657], protocol=IMAP
Oct 4 12:04:17 webserver1 pop3d: LOGOUT, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49652], top=0, retr=0, rcvd=24, sent=1550, time=1
Oct 4 12:04:17 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:04:17 webserver1 pop3d: LOGIN, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49658]
Oct 4 12:04:17 webserver1 pop3d: LOGOUT, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49658], top=0, retr=0, rcvd=24, sent=133, time=0
Oct 4 12:04:55 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=96, sent=500, time=39
Oct 4 12:04:55 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=65, sent=202, time=39
Oct 4 12:09:17 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:09:17 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:09:17 webserver1 pop3d: LOGIN, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49684]
Oct 4 12:09:17 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49686], protocol=IMAP
Oct 4 12:09:17 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:09:18 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49688], protocol=IMAP
Oct 4 12:09:18 webserver1 pop3d: LOGOUT, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49684], top=0, retr=0, rcvd=24, sent=1550, time=1
Oct 4 12:09:18 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:09:18 webserver1 pop3d: LOGIN, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49689]
Oct 4 12:09:18 webserver1 pop3d: LOGOUT, user=web2_mtutaj, ip=[::ffff:99.39.166.185], port=[49689], top=0, retr=0, rcvd=24, sent=133, time=0
Oct 4 12:09:56 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=96, sent=500, time=38
Oct 4 12:09:56 webserver1 imapd: LOGOUT, user=web10_mtutaj, ip=[::ffff:99.39.166.185], headers=0, body=0, rcvd=65, sent=202, time=39
Oct 4 12:14:26 webserver1 pop3d: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:14:26 webserver1 imapd: Connection, ip=[::ffff:99.39.166.185]
Oct 4 12:14:26 webserver1 pop3d: LOGIN, user=web9_mike, ip=[::ffff:99.39.166.185], port=[49712]
Oct 4 12:14:26 webserver1 imapd: LOGIN, user=web10_mtutaj, ip=[::ffff:99.39.166.185], port=[49715], protocol=IMAP
let me know if you see anything from this.
Reply With Quote
  #8  
Old 5th October 2009, 17:31
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I posted my log, but it told me that it needed mod approval.
Reply With Quote
  #9  
Old 5th October 2009, 20:28
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 152 Times in 132 Posts
Default

Quote:
Originally Posted by mtutaj View Post
I posted my log, but it told me that it needed mod approval.
Due to a lot of spam lately we needed to activate a new spam filter.
Unfortunately is this filter seeing a lot of post like your log file as spam.
Only admins and moderators can "okay" a post when it's marked "mod approval".

I've approved your post, and it should now be readable.
Sorry for any inconvenience.

Last edited by edge; 5th October 2009 at 20:31.
Reply With Quote
  #10  
Old 5th October 2009, 20:31
mtutaj mtutaj is offline
Junior Member
 
Join Date: Sep 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

cool, thanks,
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Create user and email script TheRudy Programming/Scripts 0 7th June 2008 11:15
log files cruz Technical 3 15th May 2007 14:35
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 10:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.